By using this site you agree to the use of cookies for analytics, personalised content and ads. Read more

Skype Community has moved

You can find the new Skype Community here. For more information please read this post.

iphone doesnt ring

Go to solution
Novel Tourist
There is no preferences setting using the Skype for iPhone app or using on the web site. I've tried everything else. I'm sure the app just doesn't ring long enough but I can't find this preferences tab.
Flag for a Moderator
Message 11 of 38
Casual Adventurer

I have the latest version of ios

But ever since installing the latest version myiphone does not ring if the application is running in the background


I have been using iphone with skype for four years

Flag for a Moderator
Message 12 of 38
Novel Adventurer

I checked my settings and learned that I had already done all of the above, but my iPhone still doesn't ring when I receive a Skype call.  Are there any other settings I need to change??? thx

Flag for a Moderator
Message 13 of 38
Casual Adventurer

Yes mine is the same issue

All settings are correct but it still does not ring

Flag for a Moderator
Message 14 of 38
Novel Adventurer

The solution doesn't work on my iPhone or on my wife's iPhone.  Does anyone have any other ideas?  Skype works great on my home computer (Microsoft)...

Flag for a Moderator
Message 15 of 38
Casual Tourist

If skype runs in background it should ring once you get calls. You should check the setting in Setting > skype > alert and setting > notification center >. Mine works IFFF it is running in the background otherwise it doesn't.  

Flag for a Moderator
Message 16 of 38
Novel Adventurer

tried all the list needs to do but still not working... (

Flag for a Moderator
Message 17 of 38
Novel Adventurer

I am having the same issue as everyone else who already posted. My iPhone 5 does not ring if it is in locked mode.  It only rings if I am on the home screen in active mode.  This is very frustrating.


I have followed all the recommended steps, and it does not help.  I have given up and set it to forward my calls to my mobile -  I hope that works.  But I would like to use video skype calling so this is a drag.


On the locked screen or asleep screen, I only get a very brief alert.  No sounds.  If I happen to be staring at the screen, I see the alert briefly, but there is no time to answer the call even if I'm waiting for the call.  This is clearly not working right. I wonder if Apple is sabotaging our use of Skype on iPhone so that people will switch to Facetime?


I hope someone finds a solution for this.

Flag for a Moderator
Message 18 of 38
Novel Tourist

I found the solution that workes at list for me

For iphone 4

Go to Settings

Found the Skype app

Go to Sounds make it be with the green color (slide)

Now I have my Skype working without problem!!



Flag for a Moderator
Message 19 of 38

I have had the same issue with numerous phones.. iPhone, Android, Nokia. My friend has also had this problem and so has my wife. In fact, five minutes ago we were both chatting via Google chat and trying to co-ordinate a Skype call. Neither could ring the other person. Also had Skype running on my computer and this didn't ring. The person calling just rings and rings and rings. NO evidence of a call being received by the other party.


This, in combination with slow-to-deliver IM's has proven enough. I am done with Skype and likely will be my wife and extended family. And after spending ALOT of money on Skype credit over the years. Sorry to post this here!  

Flag for a Moderator
Message 20 of 38
Discussion Stats