By using this site you agree to the use of cookies for analytics, personalised content and ads. Read more

iphone hangs up when incoming call

This topic has been archived. To keep discussions in the Skype Community relevant we archive topics that haven't seen activity in the past 6 months. Read more about about archiving
Casual Tourist

On skype to skype calls, when receiving calls from another skype subscriber, my i-phone declines the call. I can call out but seem not to be able to get calls in. How do I fix that.

Message 1 of 6 (3,953 Views)
5 Replies
Novel Tourist

I would love to know the answer to that as my phone is doing exactly the same

Message 2 of 6 (3,889 Views)
Novel Tourist

I'm having this problem too! there seems to be loads of people on here with it, but no satisfactory answers from Skype!!!

 

Sort this out please!

Message 3 of 6 (3,873 Views)
Novel Adventurer
I agree why don't they figure this out,. It worked before all the upgrades
Message 4 of 6 (3,844 Views)
Casual Tourist

Fixed it for me  -  iOS 5.1 on 2 iPhone 4's - I was setting up my iPhone and my wife's for the same version of the Skype app.  My outbound calls would hang up immediately and hers would work with no problem.  The fix?  I logged out of all of my instant messenger apps - Windows Live Messenger was still logged in - in the background.  Once I logged out of it the Skype app worked perfectly.  Skype should have a basic FAQ page that bullet points quirks like this.  I only figured it out because I knew our phones were identical and I knew how differently she uses hers compared to mine.

Message 5 of 6 (3,792 Views)
Casual Adventurer

I had the same problem of when calling an iPhone or Android phone that the other person's phone rang but the phone call got dropped, hung up by the other phone of Skype. I did a Skype support chat with a Skype tech person and it turned out the problem call settings under the options under the Tool menu item on the Skype app, I circled the two check boxes that must be checked ("Show Call controls when Skype is in the background" and 'Answer incoming calls automatically").  See attachment  It fixed the problem!!

 

Message 6 of 6 (1,348 Views)
Discussion Stats
  • 5 replies
  • 3954 views
  • 1 kudo
  • 6 in conversation