By using this site you agree to the use of cookies for analytics, personalised content and ads. Read more

Skype no longer runs properly in the background on iPhone 4 with iOS 5.01

This topic has been archived. To keep discussions in the Skype Community relevant we archive topics that haven't seen activity in the past 6 months. Read more about about archiving
Routine Adventurer

If skype is running in the background I don't get notifications of messages (I don't really want them anyway) or calls (I do want them).  It used to work fine but it doesn't work at all anymore.  I have the notifications turned on the settings, I have sign in automatically and I have sign out never.  If someone calls or messages while skype is not in the foreground nothing happens.  As soon as I open skype (bring it to the foreground) I see all kinds of missed calls. 


If skype is open and in the foreground I receive the calls no problem.


Why is this happening and how do I fix it?  I tried uninstalling and reinstalling skype and it didn't help at all.


20 Replies
Reliable Adventurer

I'm having the same problem: iPhone 4S with iOS 5.0.1

Reliable Adventurer
I think I found it: go to Settings, Notifications, and make sure that you have notifications configured for Skype. Seems to be working now.
Routine Adventurer

That was it.  I didn't realize there were two different places to set notifications (kind of dumb isn't it?).

Now here is the big question.  Can I make it so I only get notifications for calls and not messages?  I hate when my phone is buzzing and vibrating every time somebody sends me a message.  It's super annoying.


Also is there a way to stop chat history from being sent to my phone?  Even though I have history completely disabled on my desktop whenever I log in on my phone all the history comes in at once and it slows the phone to a crawl.  It's terrible.


Novel Adventurer
I have changed both notifications in settings and skype and STILL it doesn't work... its supposed to be on all the time running in the background, but I only see missed calls and messages when its in the foreground... help pls...
Novel Tourist

I had the same problem but noticed that on my iphone my status in skype was set to "offline" when I changed it to "online" all my notifications started coming in.

Novel Tourist

I have the same xact problems.  I have all my notifications on (in both places) and my setting is to never log off and auto sign  in.  Yet after a while if I go check the app, it'll show that I'm offline.  WTF?!?!?!  Then I have to start the app again and then again will be online for a little bit of time and be kicked offline again.  I havent ever seen what that idle time is that it kicks you off.  

would love a fix to this! very annoying!!!




Our development team is aware of the problems around background running and notifications and we are currently trying to fix it. Unfortunately it is not possible to tell you when exactly it will be fixed. 


Please keep an eye on our blogs and on iTunes updates.


I am sorry for the inconvenience. 

If answer was helpful please give Kudos and if issue is resolved mark it with solution for other users. Thanks!
Novel Adventurer
It would be a big help if this problem gets solved. Everytime I run the application in the background i get signed out.
Routine Adventurer

Please while you're at it make a way to turn off message notifications.  I want calls not message notifications on my phone.  Make the app work more like Viber!

Discussion Stats
  • 20 replies
  • 9 kudos
  • 13 in conversation