By using this site you agree to the use of cookies for analytics, personalised content and ads. Read more

Skype icon must be open to receive calls?

SOLVED
Go to Solution
This topic has been archived. To keep discussions in the Skype Community relevant we archive topics that haven't seen activity in the past 6 months. Read more about about archiving
Novel Adventurer

I'm new to skype on my iPhone. Do I have to have the Skype icon open to receive a call? If so, how do you have it open all the time? Today I opened the icon and it said I had two missed calls from yesterday, but I was on 3G all day, so it seems like you have to have skype open to receive calls. But how do you always have it open on an iPhone?

 

Thank you!

Message 1 of 15 (24,610 Views)
1 Accepted Solution

Accepted Solutions
Super Adventurer
Solution
Accepted by Kadri (Former Staff)
‎28-08-2015 11:00

clh3y wrote:

I'm new to skype on my iPhone. Do I have to have the Skype icon open to receive a call? If so, how do you have it open all the time? Today I opened the icon and it said I had two missed calls from yesterday, but I was on 3G all day, so it seems like you have to have skype open to receive calls. But how do you always have it open on an iPhone?

 

Thank you!


On the iOS devices (iPhone, iPod Touch, and iPad), you have to add Skype to the Notification Center to receive calls when the Skype app is in the background.  The Notification Center is in the iPhone's Settings.  When you add Skype to the Notification Center, make sure to select an alert that will show up on the phone's display (a banner across the top of the display, or a larger alert in the middle of the screen).  Then turn on the 3 other settings - Badge App Icon, Sounds, and View in Lock Screen. 

 

Once you do this, the Skype app can run in the background and get your attention when someone calls your Skype account - just like receiving a call on the phone itself. 

 

 

 

---
Patrick

Location/Ubicacion: Arizona USA
Time Zone/Hora Local: UTC/GMT -7

If this message has adequately addressed your issue, please click on the “Accept as Solution” button. If you found a post useful then please "Give Kudos" at the bottom of my post, so that this information can benefit others.

Si esto mensaje le ha ayudado, por favor haga clic en "Aceptar como solución". Si encuentra un mensaje útil, por favor "Da Kudos" al final del mensaje, por lo que esta información puede beneficiar a otros.

I am not a Skype employee. No soy un empleado de Skype.

View solution in original post

Message 8 of 15 (28,470 Views)
14 Replies
Casual Adventurer
All apps run in the background once you've opened them. So if you click on the Skype icon and then the home button it's still running. If you then double tap the home button you will have a list of all apps running in the background . Simply hold one and hit the close icon to close the app just the same as any other app..
Message 2 of 15 (24,594 Views)
Novel Adventurer

Stuiej,

 

Thanks for the reply. But I'm still confused about receiving calls on my iphone. I am not receiving calls unless I've clicked the Skype icon and have it open on my screen (even though it's running in the background). Shouldn't Skype calls come through regardless of what I'm doing on my iPhone, like regular calls?

Message 3 of 15 (24,568 Views)
Casual Adventurer
Yes they should , or at least that's how it is on mine . I haven't seen any settings on my phone that affect this , maybe worth giving Skype an email
Message 4 of 15 (24,561 Views)
Casual Adventurer
I've found this on the Skype support for iPhone page .....
If you are running Skype for iPhone on the iPhone 4, iPhone 3GS (or iPod touch 3G), you can run other applications without closing Skype using the multitasking feature. This means you can have Skype running in the background – and can receive calls and instant messages - while you have other applications open.
The iPhone 3G does not support multitasking.
Message 5 of 15 (24,558 Views)
Novel Adventurer
Thanks. Think I'm going to have to email Skype. My brother tried to call this morning (he's in Africa) and it didn't ring. It only rang after he texted me and I clicked on the Skype icon. Thanks for trying to help. I have the iPhone 4 so it should work according to what you found in the support page.
Message 6 of 15 (24,551 Views)
Casual Adventurer
It's is strange , I've not come across it on my iPhone .. Hope you get it sorted
Message 7 of 15 (24,547 Views)
Super Adventurer
Solution
Accepted by Kadri (Former Staff)
‎28-08-2015 11:00

clh3y wrote:

I'm new to skype on my iPhone. Do I have to have the Skype icon open to receive a call? If so, how do you have it open all the time? Today I opened the icon and it said I had two missed calls from yesterday, but I was on 3G all day, so it seems like you have to have skype open to receive calls. But how do you always have it open on an iPhone?

 

Thank you!


On the iOS devices (iPhone, iPod Touch, and iPad), you have to add Skype to the Notification Center to receive calls when the Skype app is in the background.  The Notification Center is in the iPhone's Settings.  When you add Skype to the Notification Center, make sure to select an alert that will show up on the phone's display (a banner across the top of the display, or a larger alert in the middle of the screen).  Then turn on the 3 other settings - Badge App Icon, Sounds, and View in Lock Screen. 

 

Once you do this, the Skype app can run in the background and get your attention when someone calls your Skype account - just like receiving a call on the phone itself. 

 

 

 

---
Patrick

Location/Ubicacion: Arizona USA
Time Zone/Hora Local: UTC/GMT -7

If this message has adequately addressed your issue, please click on the “Accept as Solution” button. If you found a post useful then please "Give Kudos" at the bottom of my post, so that this information can benefit others.

Si esto mensaje le ha ayudado, por favor haga clic en "Aceptar como solución". Si encuentra un mensaje útil, por favor "Da Kudos" al final del mensaje, por lo que esta información puede beneficiar a otros.

I am not a Skype employee. No soy un empleado de Skype.
Message 8 of 15 (28,471 Views)
Novel Adventurer

wd9ewk,

 

thank you SO much! this was the fix! oh my goodness - so simple! what a relief! i wasn't looking forward to continuing to work on this, so thank you for sharing such an easy solution. you and stuiej have been so helpful - thank you!

 

cheers,

clh3y

Message 9 of 15 (24,527 Views)
Casual Adventurer
Looks like we've both learned something new then lol . Glad its sorted )
Message 10 of 15 (24,335 Views)
Discussion Stats
  • 14 replies
  • 24611 views
  • 13 kudos
  • 6 in conversation