By using this site you agree to the use of cookies for analytics, personalised content and ads. Read more

how to turn off the skype update notifications?

Routine Adventurer

Anybody knows hot to stop the annoying skype update notifications?

 

There is no way I will do any upgrades, since skype has burned me in the past, so it would be nice to find out how to stop those...

 

Thanks 

47 Replies
Super Aviator

*lights cigarette*

 

Try disabling the Update service.

 

Click Start >> Run >> Type services.msc /s

 

Right click on the Skype Updater and click on Properties and in the Startup type box select Disabled. Click Apply and OK.

 

Restart your PC.

Regards,
Tamim
__________________________________________________________________________________________
Location - Dhaka | Bangladesh - Standard Time Zone: GMT/UTC + 06:00 hour

If one of my replies has adequately addressed your issue, please click on the “Accept as Solution” button. If you found a post useful then please "Give Kudos" at the bottom of my post, so that this information can benefit others.
Novel Tourist

Thank you! It really helped me.

Super Aviator
You are very welcome and thank you for your feedback.
Regards,
Tamim
__________________________________________________________________________________________
Location - Dhaka | Bangladesh - Standard Time Zone: GMT/UTC + 06:00 hour

If one of my replies has adequately addressed your issue, please click on the “Accept as Solution” button. If you found a post useful then please "Give Kudos" at the bottom of my post, so that this information can benefit others.
Novel Adventurer
i have done just that (disabled the skype updater service) and it has had no effect on my skype update notifications. they still come. of course, they cannot run automatically to update without my aggreeing and, but disabling the service has no connection to the notifications. apparently skype provides no way to disable or turn them off.
Super Aviator

beau909,

 

you can use a personal firewall software to block skype update server

 

http://community.skype.com/t5/Windows/Skype-crashes-after-login/m-p/1114890/highlight/true#M84454

Regards,
Tamim
__________________________________________________________________________________________
Location - Dhaka | Bangladesh - Standard Time Zone: GMT/UTC + 06:00 hour

If one of my replies has adequately addressed your issue, please click on the “Accept as Solution” button. If you found a post useful then please "Give Kudos" at the bottom of my post, so that this information can benefit others.
Tourist

My Updater appears as Disabled now, but after restarting my computer the update popup still appeared!

Novel Tourist

.....oooo its very, very helps me ... thanks a millian..,.

Casual Adventurer

I have the same. All is disabled, but everytime the pc starts, or at sign in, I get the window to "upgrade, it only takes a minute."

I am tired of it and I don't need it.

Anyone get this solved?

Casual Tourist

The Updater service does checks (and automatic updates) in the background.  Disabling automatic updates in Tools -> Options stops this service, but does not disable it.  You can disable the service via Start -> Run -> services.msc and finding the Skype Updater service.

 

You may also notice that everytime you start Skype there still remains a pop-up dialog box prompting you to install an update.  This is because Skype had already downloaded a new version in the background and was waiting for you to install.  This happened before you disabled the automatic updates and disabled the service.

 

To resolve go to Start -> Run -> c:\Users\<your username>\AppData\Local\Temp and look for SkypeSetup.exe.  Delete this file.  Exit Skype and re-launch it to verify this fixed the upgrade notifications.

 

I am still using Skype 6.9 due to the recent addition of ads.  This process helps make sure I don't get upgraded unintentionally.

 

 

Tags (1)
Discussion Stats