By using this site you agree to the use of cookies for analytics, personalised content and ads. Read more

Problem with playback device?

Novel Adventurer

It says "Problem with playback device" every time I call. What should I do?

 

90 Replies
Former Ambassador

That error message indicates Skype isn't playing nicely with the selection in Tools > Options > Audio settings > Speakers.

 

Click through to that setup page.  Click on the pull down arrow in the right side of the Speakers box.  If there are other choices there, select each one at a time, testing each with the green test button next to the box.

 

If you find a selection that tests properly, save that selection and try another call.




Please note: I do not respond to requests for help via Private Message.
Message 2 of 91 (188,972 Views)
Novel Adventurer
That doesn't work, there is no options when I get to the speakers options.
Message 3 of 91 (188,970 Views)
Former Ambassador

What version of Skype are you running?  Click on Help > About Skype for the specific version number.

 

What version of Windows?

 

 




Please note: I do not respond to requests for help via Private Message.
Message 4 of 91 (188,957 Views)
Novel Adventurer
Windows 7, version 5.8. something something.
Message 5 of 91 (188,955 Views)
Former Ambassador

Try going to Start > Control Panel > Sound.  If there are other options on the Playback tab, try those to see if any of them will work with Skype.




Please note: I do not respond to requests for help via Private Message.
Message 6 of 91 (188,952 Views)
Novel Tourist
Hi I am having the same problem and did what you said to do but it is still not working. Do you know what else I can do?
Message 7 of 91 (188,043 Views)
Community Ambassador

Santoshchibber wrote:
Hi I am having the same problem and did what you said to do but it is still not working. Do you know what else I can do?

What settings do you have for Speakers in Tools -> Options -> Audio settings? Can you hear any sound when pressing the green test button next to the Speakers settings?

Message 8 of 91 (188,032 Views)
Novel Tourist

I have the same problem.  I've adjusted the device in skype and in Windows, and I do not hear anything with the green test arrow.  When I use older versions of skype, it works.  ???

Message 9 of 91 (186,844 Views)
Casual Tourist

OH MY GOD! I figured it out. Finally! After all this time! Here's what you have to do:

 

1)Go to Control Panel.

2)Go to Hardware and Sound.

3)Click on Sound.

4)Click on your default speakers, and select as "Default Speakers".

5)Click on properties.

6)Go to the "Advanced" tab.

7)Click on "Restore Defaults".

 

 Tip: Don't forget to press "OK".

You're done with the system part!

 

1)Now, go to Skype.

2)Go to Tools>Options.

3)Click on Audio Settings.

4)Click on the green button with the arrow. If it works, you're done. Or, click on the drop-down menu, and select your default speakers. If it still doesn't work, then read on.

5)Click on "Show Advanced Options".

6)Select your default speakers, then click on move up, until it's at the very top.

7)Test your speakers!

Tip: Don't forget to save.

If it still doesn't work, (Which is weird; there is nothing more you can do, and the possibility of it not working is really low.) then I can't help you more.

 

Message 10 of 91 (186,477 Views)