By using this site you agree to the use of cookies for analytics, personalised content and ads. Read more

skype says i have a problem with my microphone

This topic has been archived. To keep discussions in the Skype Community relevant we archive topics that haven't seen activity in the past 6 months. Read more about about archiving
Novel Tourist



So i bought my first laptop computer and it came with windows 8. At first i said oh w8 looks really neat but after less than a minute i was already hating it. The fact that i cant turn off all this redesigned UI's is really annoying. So i tried to use skype, when i call or receive a call and i answer it, the call gets terminated immediately and skype that " there has been a problem with my microphone ". That is, my mic that is built in the pc.

If i use mumble teamspeak or even audacity, i can record and use the mic without problems, so its not a hardware problem, its just this crappy software. In my audio settings i have " Microphone (Realtek HD Audio)" selected.

As if this vomiting minimalistic design wasnt enough, i have to deal with configuration problems that programs that are 5 mb (audacity ) dont have.

Terrific job.

Message 1 of 26 (31,118 Views)
25 Replies
Super Aviator

Please run Skype troubleshooter.


Automatically diagnose and fix Skype audio and webcam issues

Location - Dhaka | Bangladesh - Standard Time Zone: GMT/UTC + 06:00 hour

If one of my replies has adequately addressed your issue, please click on the “Accept as Solution” button. If you found a post useful then please "Give Kudos" at the bottom of my post, so that this information can benefit others.
Message 2 of 26 (31,110 Views)
Novel Tourist

why does the troubleshoot not support windows 8,1??? Updating to this was a big mistake

Message 3 of 26 (29,250 Views)
Casual Adventurer

Same issues, microphone, also fixit doesn't work with 8.1 Just wanted tocomment - it's no wonder apple and google are leap years ahead. i've had to reset my tablet (pro 2) 3 times already - microsoft video app issues, store app issues, will it be number 4 because of skype issues?

Message 4 of 26 (29,134 Views)
Casual Adventurer

Solved it - other threads say to go to pc settings, permissions, allow apps to use microphone - well it seems skypes is not aware of this!! You also have to go into settings for skype (i.e. start skype, swipe in from the right, select settings) select permissions, allow skype to use microphone. I can now use skype ok.

Novel Tourist

The same thing happens to me do you know how to fix it?

Message 6 of 26 (28,001 Views)
Novel Tourist

Owkey i had the same problem with my computer but i will explain now to you step for step how to solve this and its pretty easy.


NOTE: this is for the winsdows 8 version not desktop. Yust saying.


Step 1: Launch Skype in the winsdows 8.

Step 2: press the flag buttom on you keyboard with the C combined.

Step 3: Click on settings.

Step 4: Click on permissions.
You will see a smal bar that will allouw you to activate is de-activate anny hardware tools from skype.

Step 5: Make sure webcame and microphone on ON.

Step 6: Call friends and have a good time :bigsmile:


Hope you can use this to enjoy your Skype experience.


Yours sincerely, 


Chris Nubcake



Message 7 of 26 (27,927 Views)
Casual Tourist

The auto fix it doesn't work on a windows 8 or 8.1 system. 

Message 8 of 26 (22,832 Views)
Novel Tourist

I did all this and still does not work?

Message 9 of 26 (21,367 Views)
Novel Tourist
The same problem
Message 10 of 26 (21,276 Views)
Discussion Stats