By using this site you agree to the use of cookies for analytics, personalised content and ads. Read more

skype is blockin my api

This topic has been archived. To keep discussions in the Skype Community relevant we archive topics that haven't seen activity in the past 6 months. Read more about about archiving
Novel Adventurer
After last week window update (Feb 13th, 2013) I notice skype is blocking my autodial.exe api that we are using for our call center.
Under Skype: Tools: Options: Advanced: Manage other programs' access to skype:
Under Manage API Access Control I can see my API
I click on "Change".
It is stating "We have blocked this program from using Skype. This is to protect your computer's security" in RED.
I see two options under it, one is grey out.
Allow this program to use skype option is grey out
Do not allow this program to use skype is selected.
I would like to know how to unblock this api.
Please let me know.
Sam Gyi
Federated Press

Message 1 of 4 (4,114 Views)
3 Replies
Super Aviator

Try Below:


Press WinKey + R to open the Run window

WinKey (the button is located between the left Ctrl and Alt with the Windows logo)



Type: regedit.exe and press Enter


delete the Skype keys from:





Location - Dhaka | Bangladesh - Standard Time Zone: GMT/UTC + 06:00 hour

If one of my replies has adequately addressed your issue, please click on the “Accept as Solution” button. If you found a post useful then please "Give Kudos" at the bottom of my post, so that this information can benefit others.
Message 2 of 4 (4,107 Views)
Novel Adventurer

Hello Tamim,


Thanks for the answer,


I look at the two locations






I do not see any reference to skype in those two locations.. I am using win 7 pro 32 bits


Please let me know.




Message 3 of 4 (4,098 Views)
Novel Tourist

I'm having this problem as well, is there any way to allow access other than downgrading?

Message 4 of 4 (3,240 Views)
Discussion Stats
  • 3 replies
  • 1 kudo
  • 3 in conversation