By using this site you agree to the use of cookies for analytics, personalised content and ads. Read more

"skype can't connect "

This topic has been archived. To keep discussions in the Skype Community relevant we archive topics that haven't seen activity in the past 6 months. Read more about about archiving
Novel Adventurer

Hi friends,

i'm using win7, since a 2 weeks i'm not able to login to skype, i verified my account and its active, checked the firewall rules both inbound and outbound are enabled, i've latest version of skype running 5.9.0.114, can some one help me out to fix the issue.

 

when i try to sign in the circle revolves for few min and finally error message displayed saying "Skype can't connect". PFA the error screen shot

 

any hlep is really apprecieated.

thanks & regards

Joshi

Message 1 of 39 (54,257 Views)
38 Replies
Esteemed Adventurer

Make sure you are connected to the Internet.

-----------------------------------------------
Please kudo my post if you found it helpful or liked it. Thanks!
Message 2 of 39 (54,232 Views)
Novel Adventurer

Thanks for your reply, its a very basic prerequisite, and I've taken care of it.

Message 3 of 39 (54,214 Views)
Tourist

I'm experiencing something similar with the same version (5.9.0.114), after an automated update. (It must have had been updated from quite an old version of Skype as I haven't used my PC for about a year). 

 

Additionally, there seems to be no way to stop the spinning circle. If I want to stop Skype I need to force it from the Task Manager.

 

I deleted %appdir%/Skype folder completely. I tried several times to uninstall, and reinstall, with restarts. Nothing has helped until now. 

 

During the upgrade it told me to close all applications, otherwise a restart will be needed. I ignored this message thinking it's some usual info. But now I wonder if this could be of any help to diagnose the problem.... 

Message 4 of 39 (54,181 Views)
Community Ambassador

Have you tried with disabled Antivirus and Firewall?

Message 5 of 39 (54,175 Views)
Novel Adventurer

yes firewalls rules are updated and enabled, i'm using Mcafee and can some one tel me does Mcafee blocks Skype ? if yes how can i allow skype via Mcafee, because i tried searching for keyword skype in Mcafee console i couldn't find.

 

thanks..

Message 6 of 39 (54,154 Views)
Community Ambassador

There have been numerous reports on problems with McAfee and Skype. Here is just one example:

 

http://community.skype.com/t5/Windows/can-t-sign-in/m-p/547505#M46394

 

Maybe this will help you with configuring your McAfee:

 

https://community.mcafee.com/thread/21070

 

 

Message 7 of 39 (54,149 Views)
Esteemed Adventurer

This is for a Windows XP (Service Pack 3, 32-bit).

This should help:

  1. On the bottom right, you might see a computer with two lines.
  2. Click on it.
  3. Click on "View Wireless Networks".
  4. Click on the wireless network you want to use.

If it is not there, you might be using an Ethernet cable for the Internet.

-----------------------------------------------
Please kudo my post if you found it helpful or liked it. Thanks!
Message 8 of 39 (53,900 Views)
Novel Tourist

I had the same problem what I did was to uninstall the version already instaled and I looked for the a 64bits version that I installed on my wondows 7 64 bits.

[invalid URL]

and then all worked fine

 

[invalid URL] 

 

Message 9 of 39 (53,638 Views)
Community Ambassador

tchouken wrote:

I had the same problem what I did was to uninstall the version already instaled and I looked for the a 64bits version that I installed on my wondows 7 64 bits.

[invalid URL]

and then all worked fine

 

[invalid URL] 

 


There is no 64-bit version of Skype. Skype is a 32-bit application but works on 64-bit Windows.

Message 10 of 39 (53,634 Views)
Discussion Stats