By using this site you agree to the use of cookies for analytics, personalised content and ads. Read more

Update failure, error code 1603

Go to solution
This topic has been archived. To keep discussions in the Skype Community relevant we archive topics that haven't seen activity in the past 6 months. Read more about about archiving
Novel Adventurer
Currently running ver but when I try to update, it fails, miserably at that. Apparently, it says that I have 5.8 installed and gives me an error code 1603. Any suggestions please?
1 Accepted Solution

Accepted Solutions
Community Ambassador

I’m not sure if this will help but you can try to run the “Fix it” from this Microsoft article:


31 Replies
Super Adventurer
this is Windows Installer issue
Novel Adventurer

Yea.. Doesn't really solve my problem..


  • Install the package to a folder that is not encrypted.
    I can't install the update if I can't remove a version I don't have.
  • Install the package to a drive that is not accessed as a substitute drive.
    Don't have a substitute drive.
  • Grant Full Control permissions to the SYSTEM account. (for Windows 2000 and Windows XP only)
    Yea, I have Windows 7.


Novel Adventurer
Any one else with any solutions?
Community Ambassador

I’m not sure if this will help but you can try to run the “Fix it” from this Microsoft article:


Novel Adventurer

I've run into the same problem and since non of skype support systems was either reachable or could be connected, nor was it helpful. I decided to do it the dirty way as I am a developer myself and know what I am doing, or at least I hope so... (coming from version but same with the I just saw your post when I was trying to find the 1603 error in the FAQ:


goto C:\ProgramData\Skype\


there will be various folders (depending on how many versions you had installed previously) with {kombinationoflettersandnumbers} choose the one the error message was referring to.


within that dir you will find a <file>.msi for me it was was skype.msi

Just rename it the way the Skype update wants it to be called (in my case it was SkypeSetup_5.8.0.154/


The problem seems to be that the skype installation will not be able to find or rename the original msi installer of the older/previous version installed (for uninstalling purposes) but will use any other as long as it has the same name. Keep in mind that this is a dirty way and I'm sure that it is not supposed to work this way, but for me it did as I expected.


There definitely is an error either in the install (if the msi is needed for uninstall it should be stored somewhere in the program's dir) or the download/update routine but I have other things to do then other people's job. I was annoyed enough to do it cause it will influence the install on approx 200 machines here but decided different as I could solve it using the way described above.

Novel Adventurer

ruwim wrote:

I’m not sure if this will help but you can try to run the “Fix it” from this Microsoft article:


YESSSSSSSSSS!! This worked for me!!! +1 to you sir

Novel Adventurer

Having same problem coming up from

Is it a Skype or Microsoft problem??

Looks like Skype to me - are the going to fix it??

Novel Adventurer

Used the Microsoft "Fix" and Downloaded Skype - so have new version =

Novel Adventurer

I had this annoying persisting problem for weeks, until I found a great solution:


1. In your Skype application go to Help > About Skype.

2. Write down the exact version in this format: X.X.X.XXX

3. Go to this site to download a new installation file.

IMPORTANT: You must find exactly the same version as you have installed!!!

4. Download the installation file.

5. Run the installation. It will install "on top" of your old installation - and you will find the full uninstall information as well. You will find it in the Control panel > Programs and applications.

6. When you have installed Skype - it worked smoothely for me -  check for updates. In a couple of minutes I had the old version uninstalled and the brand new version on my computer :-)

I run Windows 7 Home Premium.


This worked for me on 2012.11.15 - Hopefully it will for you too :-)

Good luck! - Bertil in Sweden


Discussion Stats