By using this site you agree to the use of cookies for analytics, personalised content and ads. Read more

Skype plays through Headset, but other sounds play through speakers

This topic has been archived. To keep discussions in the Skype Community relevant we archive topics that haven't seen activity in the past 6 months. Read more about about archiving
Novel Adventurer

When on a call in skype, my headset will work perfectly fine with skype, but when I try do anything else (ie: play a game, watch a video) the sound plays through the speakers, please help resolve this problem.

 

DELL Inspiron

Windows 7


Message 1 of 8 (18,368 Views)
7 Replies
Super Aviator

Try Below:

 

Set the sound output to Speakers.

 

In the call, Click Call quality >> Speaker >> Set the output to your Speakers.

 

 

set the sound input to microphone.

 

In the call, Click Call quality >> Microphone >> Set the input to your microphone.

 

 

Press WinKey + R to open the Run window

WinKey (the button is located between the left Ctrl and Alt with the Windows logo)

 

 

Type: mmsys.cpl and press Enter

 

Click on Playback >> Set the speakers device as default (Set as default playback device & Set as default communication device).

 

 

Click on Communications >> Select Do Nothing >> OK.

 

 

In Skype, Go to Tools >> Options... >> Audio settings >> Make sure Speakers and Ringing both set to Speaker / Headphones >> Save changes.

 

Regards,
Tamim
__________________________________________________________________________________________
Location - Dhaka | Bangladesh - Standard Time Zone: GMT/UTC + 06:00 hour

If one of my replies has adequately addressed your issue, please click on the “Accept as Solution” button. If you found a post useful then please "Give Kudos" at the bottom of my post, so that this information can benefit others.
Message 2 of 8 (18,364 Views)
Novel Adventurer

Thanks alot Tamim, but the problem still seems to occur. I'm using a headset with a microphone aswell, but despite changing my sound settings, and my skype settings, when having a skype conversation, and playing Minecraft on Java Platform, the in-game sounds from minecraft play through my laptop speakers, but the call is fine and plays through the headset.

Message 3 of 8 (18,342 Views)
Novel Adventurer
Thanks alot Tamim, but the problem still seems to occur. I'm using a headset with a microphone aswell, but despite changing my sound settings, and my skype settings, when having a skype conversation, and playing Minecraft on Java Platform, the in-game sounds from minecraft play through my laptop speakers, but the call is fine and plays through the headset.
Message 4 of 8 (18,330 Views)
Novel Tourist

This is all assuming that you use windows 7. Go to the speaker button on the bottom right, right click on it and press playback devices right click on speakers and headphones then click disable. That will keep it from wworking witch means the only device the audio can come through is your headset. If it doesnt work then i dont know what will and to turn back on the speakers do the same thing again but click enable when you right click the speaker button.

Message 5 of 8 (17,411 Views)
Novel Tourist

DUED YOU ARE A LIFE SAVER!!!!!!!!!! OMG thank you SOOOOO much! Now I can record more games for youtube! You are the best!

Message 6 of 8 (14,564 Views)
Novel Tourist

This is a really old thread, but I wanted to share what I did so that both my Skype call and my video/game audios both play in my headset. This is for Windows 7, assuming you have the same setup that I have.

 

Control Panel > Manage audio devices > Disable 'Independent Headphones' so that 'Speakers and Headphones' is set as default.

 

 

Then play a video and call the Skype call testing service and see if it works for you.

Novel Tourist

Wow, Im a moron. I disabled the headset and it fixed my problems that I have been having for months, I had set that to be a part of my system and never figured that it split the jobs so that the sounds wo go to seperte "speaker" sources. Thanks : )

Message 8 of 8 (12,260 Views)
Discussion Stats
  • 7 replies
  • 18369 views
  • 5 kudos
  • 6 in conversation