By using this site you agree to the use of cookies for analytics, personalised content and ads. Read more

Skype changing how phone numbers are displayed on webpages

Go to Solution
This topic has been archived. To keep discussions in the Skype Community relevant we archive topics that haven't seen activity in the past 6 months. Read more about about archiving
Novel Adventurer

I find the automatic conversion of any phone number appearing on a webpage into a Skype action bar to be extremely annoying. As a web designer, I find it unacceptable, because it messes with my layout, and I can't see what "non-Skype" people see.


I hope that there is some way of telling it to stop doing this, or I will be forced to uninstall Skype on my main work computer. Please let me know how to stop it. Thank you.

Message 1 of 11 (5,650 Views)
1 Accepted Solution

Accepted Solutions
Community Ambassador
Accepted as a solution by wickenden
‎28-08-2015 11:00
Message 2 of 11 (6,311 Views)
10 Replies
Community Ambassador
Accepted as a solution by wickenden
‎28-08-2015 11:00
Message 2 of 11 (6,312 Views)
Novel Adventurer

Thank you, that fixed it!

Message 3 of 11 (5,613 Views)
Novel Tourist
Really appreciate this concise and correct solution.
Message 4 of 11 (5,281 Views)
Casual Tourist

The solution posted here removes the skype number formatting only on that specific machine where you have removed the skype toolbar. However, other people who visit your website will have the skype formatted number (if they are skype users who didn't uninstall the toolbar).


To solve this without un-installing the toolbar, just add this meta tag to the head section of your web page. It basically tells skype toolbar not to format any numbers




I found this solution long time ago when I had this issue and it worked for me. Hope this helps!


Mohamed Elgharabawy

Message 5 of 11 (4,934 Views)
Novel Adventurer

Doesn't work for me sadly, I think that meta tag has been usurped! Skypes insideous nature will not go UNCHECKED! I will be back with a better solution hopefully when I have found one.

If Skype would like to interject here and inform us on how to disable the toolbar from hyjacking my website's telephone numbers, well, that would be just great, it could save web developers like me a lot of time and my client's a lot of money!

Message 6 of 11 (4,138 Views)
Novel Adventurer

I managed to get it to work by putting the number in random spans, of random length, so as to SEMANTICALLY not define it as a telephone number.


Please don't go and ruine this for me Skype. Thanks

Message 7 of 11 (4,135 Views)
Casual Adventurer

This seems like the right solution, but when I click on the link it tells me "Access Denied" and that I don't have sufficient privileges.  Any other suggestions?

Message 8 of 11 (3,875 Views)
Community Ambassador
Casual Adventurer

I was able to find another fix.  If Click to Call is enabled on Internet Explorer, there will be a small Skype icon on the toolbar.  Click on it and click "uninstall."  Then close the IE browser and reopen.  It worked for me.

Message 10 of 11 (3,866 Views)
Discussion Stats
  • 10 replies
  • 2 kudos
  • 7 in conversation