By using this site you agree to the use of cookies for analytics, personalised content and ads. Read more

Skype Active X error (because of ads)

SOLVED
Go to Solution
This topic has been archived. To keep discussions in the Skype Community relevant we archive topics that haven't seen activity in the past 6 months. Read more about about archiving
Reliable Adventurer

Hi. I get Skype ACTIVE X ERROR LIKE THIS 

"One or more ActiveX controls could not be displayed" 

whenever I login to Skype. I discovered somehow Skype was trying to connect to IE to display ads. Please fix this error ! I don't want to see Active X error messages all the time whenever I login to Skype! FIX YOUR ADS , SKYPE DEVELOPERS!

Message 1 of 41 (36,984 Views)
1 Accepted Solution

Accepted Solutions
Reliable Adventurer
Solution
Accepted as a solution by alicarikcioglu3
‎28-08-2015 11:00

done that. and made IE Active X settings to zero restriction. Both did not help. Skype should have own system to display own ads!! big problem !!

View solution in original post

Message 3 of 41 (37,149 Views)
40 Replies
Community Ambassador

Skype uses IE in the background whether you use IE or not.  To me that error means your IE Active X settings are too restrictive.  Not that Active X is broken.  This usually happens when you have custom IE settings.  It's just a warning box that can come up if anybody's IE is set up in that fashion.  You can make modifications to those specific settings in your Internet Options or just reset your IE settings.

 

You can use the Fixit tool or follow the links on the page to do it manually.

 

http://support.microsoft.com/kb/923737#fixit4me

 

Message 2 of 41 (36,974 Views)
Reliable Adventurer
Solution
Accepted as a solution by alicarikcioglu3
‎28-08-2015 11:00

done that. and made IE Active X settings to zero restriction. Both did not help. Skype should have own system to display own ads!! big problem !!

Message 3 of 41 (37,150 Views)
Reliable Adventurer

I didnt have this problem until version 6.

Message 4 of 41 (36,968 Views)
Community Ambassador

I imagine it could happen due to Antivirus/Firewall or other adblocker/plugin software.  Microsoft owns IE, so I guess it's all their software to be used as they see fit.  Whether that's a wise decision or not.  I have version 6.3 installed on most of my machines and  I have not run into any ActiveX related errors when using Skype while the ads pop-up.   If the problem is only local to a single computer you can try upgrading to the latest IE or downgrade Skype if it becomes too much of a hassle.

Message 5 of 41 (36,965 Views)
Reliable Adventurer

It's not such a huge problem right now, but it's still *a problem*. I dont use any Firewall or Anti-virus by the way. I hope Skype reads this forum and fixes this Active X problem in the next version.

Message 6 of 41 (36,874 Views)
Novel Adventurer

I have this problem as well, and to me the issue is not solved.

 

No matter the ActiveX settings, the ads in Skype keep causing issues for me. The Active X pop-up is well-known to me as I sometimes get one every other minute.

In one instance it locked up Skype when the person I was talking with initiated a screen share before I could click on the "OK" button in the Active X pop-up, leading to this pop-up window disappearing and the conversation window becoming unresponsive.

 

I would have expressed my hope that this will change in the future, but considering how Skype is now owned by Microsoft, I shudder to think of the 'wonderful ways of integrating Skype into the Windows codebase' which would most likely only aggravate the issue further.

I do hope the Skype developers will prove me wrong on this, but I am already exploring other VoIP options just in case.

Message 7 of 41 (36,640 Views)
Casual Tourist

open the internet explorer and download and install the flash player through it. i had the same problem searched it online, found this solution, tried it and it worked for me! u just have to install the flash player through the internet explorer and not google chrome or mozilla! hope this fixes it for you no idea though why it happens or why its fixed this way!

Message 8 of 41 (36,548 Views)
Community Ambassador

stelakis wrote:

open the internet explorer and download and install the flash player through it. i had the same problem searched it online, found this solution, tried it and it worked for me! u just have to install the flash player through the internet explorer and not google chrome or mozilla! hope this fixes it for you no idea though why it happens or why its fixed this way!


The reason for this is that Skype is using Internet Explorer installed on your computer to download and play ads using Flash Player. Therefore, you need a version of Flash Player that works with your IE.

Message 9 of 41 (36,546 Views)
Novel Adventurer

I'm having this problem as well, I tried to do uninstall and reinstall my flash player from internet explorer but while I was easily able to uninstall I can't seem to find the link that will allow me to reinstall. I don't know what's going on, but it's annoying and I hope it gets fixed or at least looked at soon.

Message 10 of 41 (35,320 Views)
Discussion Stats