By using this site you agree to the use of cookies for analytics, personalised content and ads. Read more

One or more ActiveX controls could not be displayed because either ...

SOLVED
Go to Solution
This topic has been archived. To keep discussions in the Skype Community relevant we archive topics that haven't seen activity in the past 6 months. Read more about about archiving
Casual Adventurer

I get that message when I open skype 

The only solution until now which I read about ( http://www.sevenforums.com/software/132215-when-i-open-my-skype-extras-message-appears.html ) was to enable the download of unsigned activex controls, which I think could be a little bit dangerous? Maybe I can allow one specific control or skype should sign its own controls?

 

Thanks in advance


Message 1 of 21 (56,960 Views)
2 Accepted Solutions

Accepted Solutions
Community Ambassador
Solution
Accepted as a solution by weeeee
‎28-08-2015 11:00

OK. If the error is triggered by advertisements, then this might be a known problem. Some of the advertisements are buggy and don’t work properly. However, if you are seeing animated advertisements, they are most likely run by Adobe Flash Player installed on your computer and the problem might also be with your Flash Player for Internet Explorer. Do you have the latest version installed?

 

http://get.adobe.com/flashplayer/

 

Another solution is to set your Skype in Compact View mode and close the Home page window. The advertisements will not be shown and this might also resolve the issue.

View solution in original post

Message 4 of 21 (57,118 Views)
Casual Adventurer
Solution
Accepted as a solution by weeeee
‎28-08-2015 11:00

I can't reproduce the Problem anymore (even in Default View). So I think it got fixed on the other side (the website Skype is displaying in the 'Skype Home' Section). But if the error should come again, a Workaround is to switch to Compact View.

View solution in original post

Message 9 of 21 (57,054 Views)
20 Replies
Community Ambassador

What is the version of Internet Explorer installed on your computer? In Internet Explorer go to Help -> About Internet Explorer.

 

Also in Internet Explorer try to reset all security settings to default.

 

Tools -> Internet Options -> Security: Press the button "Reset all zones to default level".

 

P.S. Please, don’t say that you are not using Internet Explorer. This is irrelevant. Skype depends on Internet Explorer.

 

 

Message 2 of 21 (56,938 Views)
Casual Adventurer

Version: 9.0.8112.16421

Update Versions: 9.0.9 (KB2722913)

 

The "Reset all zones to default level" button is grayed out, so I assume it is default (probably because I don't use IE  )

 

The error also doesn't come always, it seems to depend on which advertisement is shown (random?)

Message 3 of 21 (56,934 Views)
Community Ambassador
Solution
Accepted as a solution by weeeee
‎28-08-2015 11:00

OK. If the error is triggered by advertisements, then this might be a known problem. Some of the advertisements are buggy and don’t work properly. However, if you are seeing animated advertisements, they are most likely run by Adobe Flash Player installed on your computer and the problem might also be with your Flash Player for Internet Explorer. Do you have the latest version installed?

 

http://get.adobe.com/flashplayer/

 

Another solution is to set your Skype in Compact View mode and close the Home page window. The advertisements will not be shown and this might also resolve the issue.

Message 4 of 21 (57,119 Views)
Casual Adventurer

I do not have Flash installed and I don't want to install it. It does not make sense to me that I get an error for not having Flash

 

But Compact View mode seems to solve the problem for me :bigsmile:

There was a time when Skype refused to let the Home page window closed when restarting, but since this doesn't seem to happen anymore it is a acceptable solution.

I will look at this for the next 2 days and report back.

 

Thank you.

Message 5 of 21 (56,916 Views)
Super Aviator

You must have Flash installed on your computer. Many application relies on Flash.

 

http://helpx.adobe.com/flash-player/kb/find-version-flash-player.html

 

Uninstall Flash with this utility:

 

http://download.macromedia.com/get/flashplayer/current/support/uninstall_flash_player.exe

 

Reinstall Flash with this link:

 

http://download.macromedia.com/pub/flashplayer/updaters/11/flashplayer_11_ax_debug.exe

 

Regards,
Tamim
__________________________________________________________________________________________
Location - Dhaka | Bangladesh - Standard Time Zone: GMT/UTC + 06:00 hour

If one of my replies has adequately addressed your issue, please click on the “Accept as Solution” button. If you found a post useful then please "Give Kudos" at the bottom of my post, so that this information can benefit others.
Message 6 of 21 (56,905 Views)
Casual Adventurer

"You must have Flash installed on your computer. Many application relies on Flash."

Don't think so, I use it sandboxed in Chrome and that's it.

 

But I would be thankful for some examples, can't imagine a single one.

(In terms of an client-side application)

Message 7 of 21 (56,898 Views)
Super Aviator

try to Reset Internet Explorer settings.

http://support.microsoft.com/kb/923737

 

try to delete temporary internet files

http://support.microsoft.com/kb/260897

 

now try running skype; 

Regards,
Tamim
__________________________________________________________________________________________
Location - Dhaka | Bangladesh - Standard Time Zone: GMT/UTC + 06:00 hour

If one of my replies has adequately addressed your issue, please click on the “Accept as Solution” button. If you found a post useful then please "Give Kudos" at the bottom of my post, so that this information can benefit others.
Message 8 of 21 (56,893 Views)
Casual Adventurer
Solution
Accepted as a solution by weeeee
‎28-08-2015 11:00

I can't reproduce the Problem anymore (even in Default View). So I think it got fixed on the other side (the website Skype is displaying in the 'Skype Home' Section). But if the error should come again, a Workaround is to switch to Compact View.

Message 9 of 21 (57,055 Views)
Community Ambassador

The problem with these commercial ads is often periodic. On several previous occasions Skype has “learned the lesson” and removed or modified the buggy ads.

Message 10 of 21 (56,852 Views)
Discussion Stats
  • 20 replies
  • 56961 views
  • 4 kudos
  • 12 in conversation