By using this site you agree to the use of cookies for analytics, personalised content and ads. Read more

GetLogicalProcessorInformation fatal error

This topic has been archived. To keep discussions in the Skype Community relevant we archive topics that haven't seen activity in the past 6 months. Read more about about archiving
Casual Adventurer

Hi ,

after the latest update, skype no longer works on my desktop (on the iphone it's fine)

I have IE8 , also tried to install it again, but nothing.

When I try to open skype  I get a "fatal error" pop up

Please help

 

Message 1 of 12 (1,500 Views)
11 Replies
Community Ambassador

daniapo wrote:

Hi ,

after the latest update, skype no longer works on my desktop (on the iphone it's fine)

I have IE8 , also tried to install it again, but nothing.

When I try to open skype  I get a "fatal error" pop up

Please help

 


What exactly is the "fatal error" saying?

Do you have Service Pack 3 installed?

Message 2 of 12 (1,492 Views)
Casual Adventurer

It says  " Failed ti get proc address for GetLogicalProcessorInformation (kernel 32.dll)

Message 3 of 12 (1,479 Views)
Casual Adventurer

I just found out that I may not be able to install SP3 because  I'm on a 32 bit

is it correct?
 then I can no longer  use skype on my desktop??

 

Message 4 of 12 (1,476 Views)
Community Ambassador

daniapo wrote:

I just found out that I may not be able to install SP3 because  I'm on a 32 bit

is it correct?
 then I can no longer  use skype on my desktop??

 


No, this is not correct. You can install SP3 on 32-bit Windows XP.

 

http://windows.microsoft.com/en-us/windows/help/learn-how-to-install-windows-xp-service-pack-3-sp3

Message 5 of 12 (1,473 Views)
Casual Adventurer

I followed the instruciton to install  SP3 but it didin't work

Is there a way I can install the previous version  of Skype?

 

Message 6 of 12 (1,450 Views)
Community Ambassador

daniapo wrote:

I followed the instruciton to install  SP3 but it didin't work

Is there a way I can install the previous version  of Skype?

 


The last version that may work without SP3 installed is 6.6.0.106.

 

http://download.skype.com/msi/SkypeSetup_6.6.0.106.msi

 

 

Message 7 of 12 (1,447 Views)
Novel Tourist

ooo

 

Message 8 of 12 (1,006 Views)
Casual Adventurer

The link for the 6.0 version worked and I used skype fine for a year. This morning it did an authomatic update and now Ihave the same issue with the fatal error

Your link no longer works, can u send it again please?

Message 9 of 12 (783 Views)
Community Manager

Download links for older Skype versions are not provided any longer.

You should look at getting the upgrade to SP3 done ( http://windows.microsoft.com/en-us/windows/help/learn-how-to-install-windows-xp-service-pack-3-sp3 )... But given that support for XP has ended I recommend upgrading to a newer Windows version now.


Found a helpful message? Give it a Kudo below to say "thanks" ¦ Latest Community News
Did my reply answer your question? Accept it as a solution to help others, Thanks.
Message 10 of 12 (779 Views)
Discussion Stats
  • 11 replies
  • 1501 views
  • 3 kudos
  • 5 in conversation