By using this site you agree to the use of cookies for analytics, personalised content and ads. Read more

Critical bug Skype simple message crush client

This topic has been archived. To keep discussions in the Skype Community relevant we archive topics that haven't seen activity in the past 6 months. Read more about about archiving
Novel Adventurer

If somebody (or yourself)anywhere send message with "http://:" without quotes it will crash skype. Clearing chat history not helps, because when skype download chat history from server, it will crash again.


This working on Windows 7, russian locale, have this issue on work and home PC. Please do something.

See more topics labeled with:

Message 1 of 16 (25,300 Views)
15 Replies
Reliable Tourist

This also working on Windows 8.1 and Android (skype version

Message 2 of 16 (25,263 Views)
Novel Adventurer

Deleting sent message which contain "http://:" solution this problem on Windows 7. But on Windows 8.1 all the same crashed after start.
As a temporary solution I use metro style skype for Windows 8.1

Message 3 of 16 (25,201 Views)
Novel Adventurer

I am using Windows 10 so it may be different, but have you tried updating Skype? I am on version I can send messages that contain http:// without any problems. Also it may be different because I am using English not Russian.

Message 4 of 16 (25,056 Views)
Novel Adventurer

Did you send message containing "http://" or "http://:" ?

Message 5 of 16 (25,041 Views)
Novel Adventurer

Actually OP is right, I didn't notice the trailing colon before. Putting "http://:" in will give you a memory access violation. If someone wants to throw skype into IDA Pro or debug it somehow it looks like something bad. It looks like the program attempts to read from protected memory space and the Windows kernel stops it. This occurs with Skype



Anyone good enough with assembly to know how to put some malicious instructions at memory address 00000004?

Message 6 of 16 (25,023 Views)
Casual Adventurer
How to overcome this? How to be able to use Skype again?
Message 7 of 16 (24,989 Views)
Novel Adventurer

Are you able to open Skype now at all? Even if you don't click the conversation that includes the "http://:"?


If so, have you tried clearing your history and setting "keep history for" to "no history". This setting can be found under tools > options > IM & SMS > show advanced options > keep history for


Like this:



Also if you can, you should download the skype installer from and reinstall/update or click help > check for updates in the skype menu. Skype will not actually let me send a message containing that string so I cannot reproduce the problem. It would be interesting to see if I can crash my skype client by sending myself a message from pidgin or some other IM client containing that string though.

Message 8 of 16 (24,887 Views)
Casual Tourist

I have the same issue, I was sent that message "http://:" and my Skype crashed.

Reinstalling didn't help. It seems I don't have Skype anymore.

Using Windows 7, English.


UPD: skype works on

Message 9 of 16 (24,722 Views)
Casual Adventurer
You can send it from windows 8 metro app

I used SQLite to delete the offending conversation (Messages) but still, history is downloaded from cloud

How can one overcome this?
Message 10 of 16 (24,704 Views)
Discussion Stats
  • 15 replies
  • 11 kudos
  • 12 in conversation