By using this site you agree to the use of cookies for analytics, personalised content and ads. Read more

Chinese/Japanese/Korean characters do not display properly on Skype 5.5?

SOLVED
Go to Solution
This topic has been archived. To keep discussions in the Skype Community relevant we archive topics that haven't seen activity in the past 6 months. Read more about about archiving
Casual Adventurer

Hi there,

 

I recently noticed that no characters show up on Skype at all, they appear only as squares, however if I copy and paste these into a different program, then the characters are displayed. This is obviously a display problem which is specific only to Skype, any suggestions? I've tried uninstalling and reinstalling in Chinese, but even on the install screen, only the header bar displayed correctly, everything within the program displayed only as squares. Also changed font to an Asian font which I use when typing Chinese, but still no success.

1 Accepted Solution

Accepted Solutions
Novel Adventurer
Solution
Accepted by Claudius (Community Manager)
‎28-08-2015 11:00

So to change font: Tools > Option > IM & SMs > IM Appearance.

 

The font I use is Microsoft YaHei.. but I'm sure other ones work.

View solution in original post

Message 15 of 35 (11,465 Views)
34 Replies
Casual Adventurer

Anyone got any ideas? I literally have none!!

Message 2 of 35 (44,754 Views)
Novel Tourist

I also have this problem as of the update. Anyone?

Message 3 of 35 (44,737 Views)
Novel Tourist
The way i solved this problem is by changing my non-unicode language from english to japanese.
to do so go to
Control panel> clock, language, and region> Change my keyboard or other input method > Administrative > change system locale> and change it to japanese or what ever language is not showing for you. This is what fixed it for me, not sure if it will help everyone.
Message 4 of 35 (44,693 Views)
Casual Tourist

Thanks a bunch for this. It solved the problem for me. I pretty much use Skype exclusively to talk to friends in Japan, so it was driving me crazy that suddenly it was impossible to write in Japanese. The fix is quick and easy. 

Message 5 of 35 (44,560 Views)
Novel Tourist

I have this issue as well. The changing of the display language to Chinese or Japanese for non-Unicode language is not a true fix, since Skype used to display all different languages correctly and be in Unicode mode. My problem started after I installed a program from China, which changed all my Chinese characters on the system to squares. After I uninstalled it, everything came back except for Skype, which continues to show squares.

Message 6 of 35 (44,543 Views)
Novel Adventurer

Hi,
 

I had a similar problem after updating. Oddly enough, having an Asian font made things worse. This seems to be an issue for people using multiple Asian languages.

A quick fix that worked for me was to change the IM font to Arial Unicode. To do that I had to click on the "Display More Fonts" button and change the Arial Unicode font to "show" in the Control Panel window that opened. Back in Skype I had to close and reopen the "Options" "IM fonts" window and then select the newly available Arial font.
Now CJK all display correctly, but they're not quite as pretty as they were.

Hope this works.

Craig 

Message 7 of 35 (44,268 Views)
Novel Adventurer

smithintaiwan wrote:

Hi,
 

I had a similar problem after updating. Oddly enough, having an Asian font made things worse. This seems to be an issue for people using multiple Asian languages.

A quick fix that worked for me was to change the IM font to Arial Unicode. To do that I had to click on the "Display More Fonts" button and change the Arial Unicode font to "show" in the Control Panel window that opened. Back in Skype I had to close and reopen the "Options" "IM fonts" window and then select the newly available Arial font.
Now CJK all display correctly, but they're not quite as pretty as they were.

Hope this works.

Craig 


This solution worked for me. However, I hope the skype dev team comes out with a fix for this consistent problem.

Message 8 of 35 (42,080 Views)
Casual Tourist

The problem with changing your language for non-unicode programs is that a lot of companies will look at that to decide which langauge to install their products in.

 

:/

 

My HP Printer is still showing all the settings in Japanese even after I changed it back.  My system language has always been English. ^^;

 

Message 9 of 35 (40,992 Views)
Novel Adventurer
Hi!

I have the version 5.9.0.115 and I have the same issue. I can't type Chinese characters, it gives me boxes. Also, when you go to Tools>Change language, all the asian languages with characters have boxes. There's definitely something wrong with Skype and needs to be fixed.

In the meantime, I tried the solution from smithintaiwan and it works. However, since the fonts ain't Tahoma anymore, your Skype is indeed less pretty...
Message 10 of 35 (40,090 Views)
Discussion Stats