By using this site you agree to the use of cookies for analytics, personalised content and ads. Read more

Blue Screen with Skype logo when starting app

This topic has been archived. To keep discussions in the Skype Community relevant we archive topics that haven't seen activity in the past 6 months. Read more about about archiving
Community Ambassador

DrXakep wrote:

The same problem.

Win8 CP x64

IE 10.0.8250.0 - Consumer Preview


The problem is with your Internet Explorer and JavaScript.

 

Look here for an appropriate solution.

 

http://community.skype.com/t5/Windows-Knowledge-Base/Empty-sign-in-log-in-window/ta-p/630627

 

Be careful with selecting the correct procedure corresponding to your Windows system and the version of Internet Explorer. In your case try to use the procedure designed for Windows 7 64-bit and IE9.

 

Message 11 of 52 (2,529 Views)
Novel Adventurer

I've done these steps before(regsvr32 failed with jscript.dll). My problem is harder than I expected. I think it's KIS 2013 to blame, because he's written his DLL instead of original one here:

[HKEY_CLASSES_ROOT\Wow6432Node\CLSID\{B54F3742-5B07-11cf-A4B0-00AA004A55E8}\InprocServer32]

Even after uninstalling KIS the key was on its place, and the most interesting thing: I can't replace KIS DLL with original (some sort of writing error). That's probably not connected with skype, because even IE10 doesn't execute javasripts.

Message 12 of 52 (2,518 Views)
Community Ambassador

I don’t have any experience with Windows 8 but maybe you can try to uninstall IE10 and install IE9. Installation of IE9 may correct registrations of jscript.dll and jscript9.dll.

 

Meanwhile you may apply this workaround, which may allow you login to Skype by forcing Skype to use the old login screen, which doesn’t require IE and JavaScript. However, be aware that some other Skype functions (e.g. Add a contact) may still not be working.

 

Quit Skype. Make sure that you don’t see any Skype.exe processes in Windows Task Manager. If necessary, then stop these processes. Open C:\Program Files (x86)\ folder. Find the Skype folder and then Phone. Right click on the Skype.exe file and select: Send to – Desktop (create shortcut). Right click on the newly created shortcut and select Properties and then the Shortcut tab. In the Target field you will see now: "C:\Program Files\Skype (x86)\Phone\Skype.exe". Click with your mouse on the text in the Target field and move your curser one space after the last quotation sign and add the text /legacylogin. The text in the Target field should now read:

 

"C:\Program Files\Skype (x86)\Phone\Skype.exe" /legacylogin

 

Click OK to save the changes. Start Skype using this new shortcut.

 

Message 13 of 52 (2,505 Views)
Novel Adventurer

Installing IE9 was my first thought, but I followed all manuals, but I didn't manage to do this.

 

And yeah, thanks for advice, now skype is alive, but as you said "Skype home" page don't work (it's loading and loading...), maybe something else...

I found a lot of KIS remains in registry, will try to cope with this problem

Message 14 of 52 (2,499 Views)
Novel Tourist
windows vista 32 bit and IE9
Message 15 of 52 (2,358 Views)
Highlighted
Community Ambassador

bryonybee wrote:
windows vista 32 bit and IE9

Try this:

 

Go to Windows Start -> All Programs -> Accessories -> Right click on Command Prompt, select 'Run as administrator'.

 

The Command Prompt window should show:

 

C:\Windows\System32>

 

If this is not the case, then in the Command Prompt type:  cd c:\windows\system32 and press Enter.

 

Type this and then press Enter:

 

regsvr32  jscript.dll

 

Next type this and press Enter:

 

regsvr32  jscript9.dll

 

After each Enter you should receive a message saying that DllRegisterServer in XXX.dll succeeded.

 

Reboot your computer.

 

Make now the test showing if your Internet Explorer can execute JavaScript.

 

Open in your Internet Explorer (no other browser but only IE) this page:

 

http://www.mistered.us/test/alert.shtml

 

Click on the “Simply Click This Button” button and watch the response.

 

Message 16 of 52 (2,355 Views)
Novel Adventurer

same problem 
Windows 7 64-bit
IE9

Message 17 of 52 (2,340 Views)
Super Aviator

ll112 wrote:

same problem 
Windows 7 64-bit
IE9


try to open this page using internet explorer

http://javatester.org/javascript.html

Regards,
Tamim
__________________________________________________________________________________________
Location - Dhaka | Bangladesh - Standard Time Zone: GMT/UTC + 06:00 hour

If one of my replies has adequately addressed your issue, please click on the “Accept as Solution” button. If you found a post useful then please "Give Kudos" at the bottom of my post, so that this information can benefit others.
Message 18 of 52 (2,334 Views)
Novel Adventurer

Neither the test results nor the User Agent String appeared.

Message 19 of 52 (2,324 Views)
Super Aviator

ll112 wrote:

Neither the test results nor the User Agent String appeared.


You may need to register vbscript.dll and jscript.dll

 

a)     Click Start.

b)     In the search box type cmd

c)     Right click and select Run as administrator.

d)     Type the following commands and press ENTER.

 

cd..

cd SysWOW64

regsvr32 jscript.dll

regsvr32 vbscript.dll

regsvr32 jscript9.dll

 

Restart your PC.

 

Now try running Skype.

Regards,
Tamim
__________________________________________________________________________________________
Location - Dhaka | Bangladesh - Standard Time Zone: GMT/UTC + 06:00 hour

If one of my replies has adequately addressed your issue, please click on the “Accept as Solution” button. If you found a post useful then please "Give Kudos" at the bottom of my post, so that this information can benefit others.
Message 20 of 52 (2,315 Views)
Discussion Stats