By using this site you agree to the use of cookies for analytics, personalised content and ads. Read more

Wrong email language

Highlighted
Novel Adventurer

In Skype settings you are required to set your preferred language.

Skype has access to this setting, and yet they choose to completely ignore it and use some bizarre method of choosing the default language for emails sent out.  

 

They also have access to the fact I have cleared the tick box accepting emails and adverts.  

Yet I still get emails from Skype, in Chinese, despite my settings saying I speak English and don't want spam.

 

 

Skype are not alone in this behaviour.  Many large companies have no idea what data they have available, and even less idea how to use it effectively.

 

 

Somebody at Skype probably thinks they were very clever to tailor email langauge to registration country and they are patting themselves on the back for it.   I'm sure it wasn't easy.  

Can somebody else at Skype please explain to them that they got it wrong?  You have access to our preferred language settings and our "opt out" settings", please use them appropriately.

 

Thank you.

 

 

 

 

 

 

 

Novel Tourist

All of my emails are in German.  If I uncheck the "no more emails" box I may miss a TOS change, but it's not like I could read it anyway. This is absurd.  Good thing you just rolled out a "hey pay us" feature like skype wifi. I suppose I'm not too surpirsed to learn MS is the parent company.

Novel Adventurer

It looks like Microsoft has no handle on getting this error fixed.  I contacted chat support and was told to change my email to a different that is active for me and then change it back in a few days.  Well that did nothing and the emails are still coming in Italian.  Thank Larry & Sergey for Google Translate.

 

Their excuse that it's based on the country of origin is lame.  I registered in the US from day one and never moved.  Looking at the dates of the complaints of other people, this has been going on for too long.  Microsoft needs to put email language selection on the profile setting to close this problem once and for all.

 

Practice safe hex,

Pete

 

Novel Adventurer

I have had the same problem - I just contacted Skype via the chat option and got it resolved in a 2-3 minutes! Easy peasy!

Casual Tourist

Ref: "The language you receive email from is derived from your account registrations location. "

I setup my skype account from the UK very early in Skype's history. I receive emails in German. I have never (yet) been to Germany.

Casual Tourist
I contacted the customer service with the same problem and asked them to stop sending me French emails since I'm not French and have never had any other language setting than English. They replied with the message that due to the many mails they get, they can, unfortunately, not help me. ?? How about they did help instead of taking those two minutes to send me that inane reply?
Casual Adventurer

I registered for Skype in the USA, and have always only selected English as my language.  Yet I receive alert emails from emails.skype.com in Spanish on a regular basis.

Why am I receiving these emails from Skype in Spanish?

Where is the setting to change from Spanish to English?

Casual Adventurer

[Text redacted which does not conform with the Community Guidelines.}

 

This has been an open and on-going concern for years. 

 

Skype and now Microsoft are too **bleep** to know how to do any form of internationalization/localization. 

 

I know it SHOULD be simple. Select a prefererred language for correspondance (defaulting to the language chosen at account creation) and just use that. 

 

This is entirely TOO difficult for Microsoft/Skype. 

 

Additionallly, The could not care less what you, as a consumer, wish. 

Novel Adventurer

I have had the same problem - I contacted Skype via the chat option and got it resolved in a 2-3 minutes! Easy peasy!

Casual Adventurer

pumpkin25 wrote:

I have had the same problem - I contacted Skype via the chat option and got it resolved in a 2-3 minutes! Easy peasy!


I have tried multiple times to get a Chat started, but it has always popped up a message that there was an X-minute long wait, then it never launched any chat that I saw (no one responded to the Chat request).  Not so easy, peasy.

Discussion Stats