By using this site you agree to the use of cookies for analytics, personalised content and ads. Read more

How to change language in all Skype email communication

Tourist

I'm having the same problem except I'm in Los Angeles, USA. My computer is from here, I signed up for my Skype account here - everything. I've never been to Asia in my life. But all my email messages are in Chinese. I thought I was hacked the first time I saw it.

Message 21 of 69 (2,217 Views)
Casual Adventurer

We'll see if it works, but I just "chatted" with Support. I was asked to change my language from the Profile page (click Edit) to another Language. Click Save, and then re-select the language of my choice. And Click Save. (So change it something else and then reset it back to the desired language). We'll see if that fixes it. 

 

 

Message 22 of 69 (2,115 Views)
Casual Adventurer

Well apparently support has no clue.I just got another email and it was in French.  L18n and I18n are not new concepts.  Fortunately I think there is legal precedent in the United States that I am not bound by the changes to any legal terms and conditions if I request and am denied information in a language I can comprehend--whether through refusal or gross incompetence. 

Message 23 of 69 (2,941 Views)
Highlighted
Casual Tourist

I signed up for SKYPE in the USA.  I used SKYPE for several years.  Email traffic was in English.  Then I traveled to Japan for several short trips.  Now all email traffic is in Japanese.  How do I get SKYPE to change it back?

Message 24 of 69 (2,916 Views)
Novel Adventurer

signed up in the UK,  always been in the UK.  Never been to China,  ever.  Now my emails are in Chinese?   Don't fob me off with some fantasy tale of it being associated to the country of creation,  as in my case that's ENGLAND where we speak ENGLISH.

 

Sort it out Microsoft,  Skype is convenient,  but there are other products out there....

Novel Adventurer

I constantly get e-mail in Dutch, despite (A) living in an English-speaking country (B) having never lived in the Netherlands (C) having always specified English in my profile. However, in the drop-down list Skype provides, Dutch is right above English. Off by one.

 

I never had this issue before Microsoft acquired Skype. How embarrassing for Microsoft that they can't get this one simple thing right.

Casual Tourist

Welcome to Microsoft's software quality!

Casual Tourist

i still wana to change language but but can't do

http://sieuthicua.info - The gioi cua cua nguoi Viet
Message 28 of 69 (1,987 Views)
Novel Tourist

I have same problem. I am English speaker and have setup my profile to use English language.  Been a member of Skype for 8+ years and had no problems with language settings.  Lately however I am receiveing email messages from Skype in Indonesian language!  My current location is Timor Leste (East Timor)!  Go figure!

Message 29 of 69 (1,768 Views)
Casual Tourist

I'm from Hungary, and I have the same problem - I'm getting the e-mails in German language... I do speak it a bit, but I didn't choose it for e-mail language! Still can't we change this setting to English or Hungarian, or whatever we want?

 

Thank you!

Message 30 of 69 (1,816 Views)
Discussion Stats