By using this site you agree to the use of cookies for analytics, personalised content and ads. Read more

Status changes to Do Not Disturb instead of Away

SOLVED
Go to Solution
This topic has been archived. To keep discussions in the Skype Community relevant we archive topics that haven't seen activity in the past 6 months. Read more about about archiving
Novel Adventurer

I am using the latest version of Skype Windows. When I set the program to switch to Away after five minutes, the result is for Skype to change the status to Do Not Disturb. That requires me to manually go back online. How can I get Skype to use Away instead of Do Not Disturb?

Message 1 of 19 (6,326 Views)
1 Accepted Solution

Accepted Solutions
Community Ambassador
Solution
Accepted as a solution by RIMorrisJr
‎28-08-2015 11:00
Message 2 of 19 (6,340 Views)
18 Replies
Community Ambassador
Solution
Accepted as a solution by RIMorrisJr
‎28-08-2015 11:00

If your PC is from Lenovo then your problem might be similar to this one:

 

http://community.skype.com/t5/Windows/Unable-to-set-quot-Away-quot-status-manually-instead-Skype/td-...

 

Message 2 of 19 (6,341 Views)
Novel Adventurer
Bingo! I am using a ThinkPad X220 and denying BlueTooth has solved the problem. Many thanks.
Message 3 of 19 (6,315 Views)
Novel Tourist

I have had the same issue on an HP Omni27.  I am expecting calls and all of sudden my status seems to be set to DND which I didn't notice and I miss the call and then investigate and realize this is what has occurred.  I have now gone into the advanced settings and disallowed access to the bluetooth helper which I hope is going to resolve this issue.  Now still need to research another issue whereas only some calls seem to be making it into voicemail and for others it just keeps ringing....

Message 4 of 19 (6,019 Views)
Novel Adventurer
I have no devices listed in my allowed section. I shut down Skype and restsarted - but it still kept switching me to "Do Not Disturb" after about two seconds.

In the end, I logged off of Skype, logged on with another account and then logged back on again. Now it's fixed. Stange.
Message 5 of 19 (5,857 Views)
Novel Tourist

I cannot hear my contacts, i think dnd is on. How do I change it?

Message 6 of 19 (5,672 Views)
Tourist

This also happened to me on an ASUS F8VA. It seems to be a Bluetooth issue, rather than a Lenovo one. The solution works fine

Message 7 of 19 (5,217 Views)
Routine Adventurer

This has nothing to do with Lenovo per se, just the latest version of Broadcom Bluetooth drivers supplied with Lenovo's laptops. I'm also having this problem on X220.

The proposed solution "Just deny access to the Bluetooth Headset Helper" is like suggesting "Don't play any music on your car's audio system" to a person that has problems with the car's audio system.

Disabling the Bluetooth Headset Helper's access to Skype takes away some useful features while using a bluetooth headset. I can still use the headset to talk on Skype, but without the helper, the "call" button on the headset doesn't end the call and doesn't accept an incoming call, the headset's display doesn't show the current talk time or caller ID on incoming call - all these features are very useful to me. However I had to disable the bluetooth headset helper because having a functional auto-away is an even more important feature, I don't want to go to Do Not Disturb mode and miss important calls and messages.

I understand that most likely the problem have to be fixed in the bluetooth software suite, but I'm also quite sure that Skype developers could add some sanity checks to prevent that kind of behavior from happening. I don't quite understand why a bluetooth software should be allowed to change the user's online status to DND anyway. At least this permission should be optional.

Would be great if Skype developers provided some kind of a workaround for this problem, because who knows how much time it would take for Broadcom to fix their software suite, and afterwards the notebook manufacturers still have to apply their own changes and package the drivers up for distribution (I can't install drivers from the Broadcom's website, only the ones I get from Lenovo).

Message 8 of 19 (3,946 Views)
Casual Adventurer

I am not using a Think Pad (just my laptop) or Bluetooth... AND AM HAVING THE SAME PROBLEMS - among others, like my credit disappearing.  

 

Even went to the trouble of cleaning every vestige of Skype out of my computer completely and downloading again - which meant going to the trouble of having to notify everyone of a new Skype address - yet still the problem persists.

 

Does anyone know how to contact Customer Service?

 

The following address no longer works, though it did in the past:  

(Skype Customer Service [mailto:en_support@skype.net]).  

Mail sent here today bounced.

 

 

So I went to their WEBSITE - followed the steps to 'email'.  Carefully filled in every box, including the stupid words that are so difficult to read.  Then went to the  'send support request' link, only to find that it will not press... IT'S DEAD!

 

 

I tried SEVEN TIMES!   Nothing!  What a waste of a morning.  I feel like screaming in frustration!

 

Now what do I do? 

Message 9 of 19 (3,931 Views)
Routine Adventurer

You don't have to use a ThinkPad specifically, or to use Bluetooth to have this problem. If your laptop uses the Broadcom bluetooth chipset, and has Broadcom's drivers installed, you might have the Bluetooth Headset Helper installed and allowed access to Skype. It might be running even if your Bluetooth is off, doing it's dirty job of changing your status to DND.

If you're using the latest Skype, go to Tools > Options, Then Advanced > Advanced settings > Manage other programs' access to Skype (at the bottom of the page). See if you have anything on the list (it might be something different from the Bluetooth headset helper), and if you do have something here, try the "disconnect" button to test if it cures your problem. If it does, you can permanently disallow that program by clicking "Change" and setting the "Do not allow" option.

 

Message 10 of 19 (3,917 Views)
Discussion Stats
  • 18 replies
  • 6327 views
  • 12 kudos
  • 13 in conversation