By using this site you agree to the use of cookies for analytics, personalised content and ads. Read more

Auto-payment

This topic has been archived. To keep discussions in the Skype Community relevant we archive topics that haven't seen activity in the past 6 months. Read more about about archiving
Novel Tourist

Dear Skype customer service officer,

 

Back a month ago I subscribed to the skype global service and disabled the auto-payment option. But to my shock skype automatically charged the monthly subcription fee to the card which I used to pay even with the auto-payment disabled. Please do something about this so the payment doesnt go through as I do not want to use this subcription service any longer. If the payment goes through, I want my refund.

 

Thank you.

Message 1 of 2 (247 Views)
1 Reply
Highlighted
Moderator

 Dear KeithTZH, welcome to the Community!

 

I am a fellow community member and volunteer. 

 

I suggest these steps:

  1.  Please sign on to your website account and ensure the auto-re-charge feature is indeed turned off.
  2.  Please ensure the subscription for which you were charged has been cancelled.
  3.  Here is a link to use to request a refund, after you are sure 1 and 2 are in place.

 

Best regards,

Elainem77

__________________________________________________________________________________________________
Was your question answered? Please click on the Accept as a Solution link so everyone can quickly find what works! Like a post or want to say, "Thank You" - ?? Click on the Kudos button!
Trustworthy information: Brian Krebs: 3 Basic Rules for Online Safety
Message 2 of 2 (234 Views)
Discussion Stats
  • 1 reply
  • 248 views
  • 1 kudo
  • 2 in conversation