By using this site you agree to the use of cookies for analytics, personalised content and ads. Read more

NetGear SPH200D problem

This topic has been archived. To keep discussions in the Skype Community relevant we archive topics that haven't seen activity in the past 6 months. Read more about about archiving
Routine Adventurer

To all:


What options do you see when you go to Menu>settings?

which are accesible and which are disabled?

i see this:


call divert
Manage blocked users

Time and date

Cordless settings
Phone settings



in this information option, i see the following:

MAC address:


IP address:

Skype username:


Firmware version:

Base RFPI:


Handset IPEI:


Copyright 2003-2006 Skype Limited

The Skype program is protected by copyright lawand international treaties. Unauthorised reproduction of this program or any portions of it may result in severe civil and criminal penalties. The Skype, SkypeIn, SkypeOut and associated logos and the "s" symbol are trademarks of Skype Limited. Portions Copyright 2001-2006 Joltid Limited. All rights reserved .Patents pending, Joltid Limited


It never says that RTX, Netgear, Topcom, Phillips or whoever manufacturer might be, that owns the software inside.

Following their logic on Skype support, whenever for ex, we have problems with any piece of software, we should claim with hardware manufacturer??!!


Where can we escalate this issue?

Message 11 of 24 (1,284 Views)
Novel Adventurer

The problem got fixed in my case, on both Netgear phones. Before signing in I chose "don't remember password for automatic sign in" and after a few attempts it simply signed in. I'm not sure if this is relevant or not, but it worked.

Message 12 of 24 (1,263 Views)
Casual Adventurer

I can log in (painfully) but can't make a call. Have you tried making a call?

Message 13 of 24 (1,249 Views)
Novel Adventurer

Can anybody answer how we get through to Skype to fix this problem urgently.  We rely on these phones for our business and have a call contract in place which we can obviously no longer use so it is affecting our business badly.


How do we get this escalated????????????????

Message 14 of 24 (1,230 Views)
Casual Adventurer

I got skype support to log this as an error yesterday, got a email today from them (my SPH200D phone just connected yesterday about 15:00, praying it stays that way ! :-



Following our chat support session, we're here to help you further with regard to your concern about the difficulties that you are encountering in connecting to Skype on your Netgear SPH200D.


We are aware of this problem and are working hard on fixing it as soon as possible. We apologize for the inconvenience that this may cause.


For regular updates on solutions, we recommend you to visit


Once again please accept our sincerest apologies, and we thank you for your patience and understanding.

Best regards,

Pretty N.
Skype Customer Service

Message 15 of 24 (1,221 Views)
Novel Adventurer

We also had a problem over this past weekend with our Netgear SPH200d not logging in to Skype. However, today it shows up as logged in and we are now receiving calls again. Anyone else experiencing a return of service?

Message 16 of 24 (1,215 Views)
Routine Adventurer
since 1h ago i was able to login again... they managed to restore functionality.
Message 17 of 24 (1,207 Views)
Casual Adventurer

Same here.

Message 18 of 24 (1,189 Views)
Novel Adventurer



I got the NetGear sph101 and I cant sign into skype at all.  I have upgraded the software but no success to sign in.


Any idea what can be wrong?


Message 19 of 24 (870 Views)
Novel Adventurer



Having fixed a similar problem on a brand new SPH101 on Sept 6th 2014, I posted my method in the skype forums on the SPH101 thread, and thought I double check there wern't other threads covering the same gound, finding this one as a result.


I'll copy in the other post below, to establish the cross reference, but what's relevant to SPH200D owners, some of whom are rightly disgruntled, and considerable sepculation, and the typically unhelpful red herrings have been thrown into the discussion, I can comfirm as of today, my SPH200D is working fine.


I purchased the very last one from Amazon for my aging parents to have a recognisable technology and user interface, that gave them skype access without having to fire up their computer.

The SPH200D actually fits that bill very well, and even runs on AAA batteries.


WARNING: Do NOT update the firmware if you have There are many, MANY posts on the netgear forums about the newer firmware builds, and the inability of NetGear to provide the version, and these date back to when the SPH200D was still supported by NetGear.


Actually I had no problems at all logging into my own 2 skype accounts, and after some testing, have factory reset the phone, and logged in with my Fathers account.


That said, at one point after I replaced the original, albeit unused netgear batteries, with new duracell ones, on powerup, the phone DID refuse to log in. After some minutes trying, it eventyually failed to log in. At this point I pointed my chrome browser to the phones IP address, and from there, selected the skype page, typed in the password, selected the "Save name and password for automatic sign in." option, and hit the signin button, which it did, and the phone responded with the audible notification.


All set, and running. I've been testing the SPH200D the last 6 days, and am now confident enough to send it to my parents.


For the record, I used a different method on the NetGear SPH101, but as this may help some SPH200D users, I've copied that post below. Sorry I can verify if this fixes a SPH200D also, because my SPH200D works very well.


SEPTEMBER 2014 UPDATE FIXED, and fully functional SPH101

Yesterday I opened a brand new SPH101, it had been sitting in its box for 6 or 7 years, amazingly the battery still had charge, and the phone fired up.

Even though this was the UK model, with UK power adapter, the phone language was in German. Fortunately for me, I have a reasonable grasp of technical German, and didn't bother to change the language until after I had connected to my wifi router, and the initial Skype login failed. Now it was time for English!

However, after changing the system language to English, rebooting, and starting over, the phone still refused to login to my skype account.

I then tried a factory reset, and it still failed.

I tried my 2nd skype account, and that also failed.

Trawled my way through the usual Google searches, obviously I found the postings here, which lead me to believe this phone may as well have stayed in its box. 

Then on whim, I tried to create a new skype account from the SPH101, and lo and behold, that WORKED.
I could make calls, added my other 2 skype accounts as contacts, and called in all directions, and everything worked great.

I then signed out of this new skype account, and retried my other skype account logins and now they too WORKED!

I'm not going to waste time speculating on why this process revived the SPH101, but indeed it did.

I realise the original posts here are somewhat dated, but in the off chance someone else would still like to use their SPH101, this is what worked for me.

FYI: SPH101 Firmware Version




Discussion Stats