By using this site you agree to the use of cookies for analytics, personalised content and ads. Read more

Skype Community has moved

You can find the new Skype Community here. For more information please read this post.

Connection problems with 1st generation Skype phones

This topic has been archived. To keep discussions in the Skype Community relevant we archive topics that haven't seen activity in the past 6 months. Read more about about archiving
Novel Tourist
No puedo iniciar la coneccion con Skipe
Flag for a Moderator
Message 61 of 143
Novel Adventurer

Received Home Phone Adapter for Skype and hooked it up and it was working fine for a few months but now everytime I try to call I get a message to check my connection with Skype. The problem is how do I contact skype to check my connection.  Please advise!!

Flag for a Moderator
Message 62 of 143
Casual Adventurer



The problem is how do I contact skype to check my connection.





 ... you do not.  ...they don't want to speak with you... they only want your money ... they are now "MicroSoft"...


...And if you got someone... they would only blame something else, like your PC or phone or the weather.....

Flag for a Moderator
Message 63 of 143
Casual Adventurer

Hi Chris2539


Thanks for the info on alternative suppliers I shall start having a look at them all.

Flag for a Moderator
Message 64 of 143
Novel Tourist

I purchased 4 GE-31591GE1 Skype phones in february and they all stopped connecting to Skype 7days ago!

What is going on?

Kindly help me restore connectivity since this is a big loss for me and my business!

The error is "Failed to Sign in" and it is also impossible to check the "Network" status or "Upgrade" the phones, there is just NO CONNECTION to Skype from the devices.

All the accounts of Skype work without an issue instead on MAC or PC.


Flag for a Moderator
Message 65 of 143
Casual Tourist

I'm still having problems with my Dualphone 3088 - sometimes toll free numbers here in Germany are working, also the Sound test number is working but as soon as I call a Hungarian landline number, which is covered by subscription, the connection can't be established. Downgrading to firmware 245 helped for about a day. Base and handset already resetted, no improvement. Firmware 250 was working flawlessly before, on changes to the network. FYI: there was no problem signing in to my Skype account.


Please fix this annoying bug ASAP!

Flag for a Moderator
Message 66 of 143
Casual Adventurer

Open Letter to SKYPE  and  Grandstream CSS:


The issues that I have discussed with SKYPE now for nearly 2 months and with GRANDSTREAM prior to that are still persisting.


SKYPE, even though they have acknowledged that they are having massive customer connection issues (below) with their so called “CERTIFIED” phones, but is still continuing to blame Grandstream…..


Connection problems with 1st generation Skype phones

13-03-2012 11:07 - last edited on 14-03-2012 20:24

We have learned that customers with certain Skype certified phones are having log-in issues. We are sorry to hear about these difficulties and we are doing our best to look into this matter to resolve these issues.

 Update (14.03.2012): We're currently gradually deploying an update on our end that should allow the certified phones to connect again. 


Here are the notes from SKYPE:


As this is a third-party appliance we are not able to offer direct troubleshooting support on issues concerning it” … .  And “… they have requested that you raise any issues with your phone (and they seem to only concern your phone, as calls go through without problem to Skype on your mobile phone) to Grandstream….”   And  “…, however the problem seems to lie with the specific product, and so we cannot directly support this."



GRANDSTREAM, of course,  is then blaming SKYPE for the lack of connection issues, saying it is in their ‘proprietary’ software.


Skype worked fine for 1 year on the GXV3140.  Now I have to reboot it, and it works fine for about 1 hour, then suddenly it seems to lose the ‘registration’ with the SKYPE servers, and I can’t get incoming calls, and sometimes can’t make outgoing calls until I log off and log back in.  So SOMETHING happened about 4-6 weeks ago that changed, either in the software on the phone, with Skype or somewhere in the connection, but someone needs to figure this out and stop pointing fingers at each other, or your customers will be leaving in large numbers.  Frankly,  I’m at a loss of why there is this total LACK of service… it really is crazy and I fail to understand it.


On top of this, almost every day I have to log in and reset the caller ID as well…. Why is that too?  Is that also GrandStream’s fault?


Please can someone help with this issue, this really has been going on way to long now.






FYI – The funny thing is, I used to brag to everyone I know about how wonderful this Grandstream phone is and how awesome SKYPE is …. Not so much anymore!


Tags (2)
Flag for a Moderator
Message 67 of 143
Novel Adventurer



I'm in HAS and recently bought Telephone 4088 in Apr, and it cannot connect to Skype since then, please advise if this is relating to the issue discuss here, and help to resolve the problem.


By the way, the landline connection is perfectly OK, it is just overtime when I try to connect Skype, I can logon but very soon the connection will be down, and I observe the network connection with Telephone is also down, then it take several minutes to have network connection resume.


Flag for a Moderator
Message 68 of 143
Novel Adventurer



I'm in HK and recently bought Telephone 4088 in Apr, but it never work to connect to Skype.


In fact, I can use Telephone to connect to landline and it works OK.


But eveytime when I try to signin Skype, the logon will success but very soon the connection signal will be lost, and I observe the network connection with Telephone also down, then it take several minutes to resume.


Please help to check and advise how to fix this problem.


Flag for a Moderator
Message 69 of 143
Casual Adventurer

Update:  Grandstream & SKYPE-


I can’t believe I am still having issues with this phone using Skype – I have done everything that Grandstream has suggested, firmware, settings,  and still I am having problems.  Grandstream is pointing the finger at SKYPE; but SKYPE says it is hardware.


(Please see note from SKYPE below).


Hello Chris,   Thank you for your reply on your current difficulties.


We are concerned about issues around your Grandstream GXV3140. However we have tried all available troubleshooting on our side, and as Skype Customer Service genuinely cannot support third-party hardware, we had no choice but to refer you to Grandstream. This is regrettable, but I hope that a solution will be found to this problem.


Thank you for keeping in touch with us, but unfortunately we have no further progress to report on this matter.


Regards, Stuart G, Skype Customer Service Specialist


Is there no way you’ll can talk to each other since this phone is supposed to be “CERTIFIED”…  why can’t you’ll figure this out?


Thank you- Chris