By using this site you agree to the use of cookies for analytics, personalised content and ads. Read more

mic not working in skype - windows 8

This topic has been archived. To keep discussions in the Skype Community relevant we archive topics that haven't seen activity in the past 6 months. Read more about about archiving
Casual Tourist


just bought new acer laptop with windows 8, which has  skype app already installed in it. Now, while echo testing, i could not hear the mic sound back, tried so many times, skype un-installed & re-installed as well. but still there is no microphone sound back to me.

but, i tried with my external headphone with microphone & it passes the echo test.

can someone help me out, what should i do.


Message 1 of 11 (18,276 Views)
10 Replies
Super Aviator

You can install ManyCam


Choose ManyCam as the audio source


Run Skype >> WinKey + C >> Settings >> Options >> Audio >> Microphone >> Select ManyCam Virtual Microphone.


Location - Dhaka | Bangladesh - Standard Time Zone: GMT/UTC + 06:00 hour

If one of my replies has adequately addressed your issue, please click on the “Accept as Solution” button. If you found a post useful then please "Give Kudos" at the bottom of my post, so that this information can benefit others.
Message 2 of 11 (18,207 Views)
Novel Adventurer
Hi Tamim,
I downloaded manycam and selected it in the dropdown menu in settings on Skpe. I did some test calls and still can't hear my recordings. My friends on the other end can't hear me although everything on my control panel and on skype say the mic and speakers are working. Do you have any other ideas?
Message 3 of 11 (18,099 Views)
Casual Tourist

Did the same, installed manyCam, could not understand how to test mic there, or it did not work there as well.

ManyCam is trying to sell pro version, but i do not know if it would help.

I have HP Winsows 8 laptop, and I wish I bought Windows 7 laptop. it is good to have touch screen, without it would not be able to get around in Windows 8 at all.

So, I have seen Timtim answer with a different advice, it mentions  calling quality screen in "call". How to find it in Windows 8 Skype?



Message 4 of 11 (16,955 Views)
Novel Adventurer

Thank you very much for your reply! I ended up taking it to a good repair shop for testing, and they recommended I just buy an external mic. It's cumbersome but works perfectly.

Message 5 of 11 (16,946 Views)
Novel Tourist

Hi All,


I had the same issue this morning with a brand new Dell Laptop with Windows 8. If your cam and mic are not working and you have done it all then you got to look at one place. Go to skype. On the right is the drop down of settings. And then PERMISSIONS. The tab to allow cam and mic is by default OFF. You got to turn that ON and BINGO!!!



Message 6 of 11 (15,564 Views)
Novel Tourist

Well done!!!!!!!!!!! that worked a treat. Duhhhhh im not computer savvy but your instructions were spot on

Message 7 of 11 (14,134 Views)
Novel Tourist

Well done badboy_tinny. YES - to get your mic to work you need to grant permission from the control panel settings.  I'm a newbee to Windows 8.  I looked and looked and couldn't find the "SETTINGS" menu anywhere.  It appears that when you put your cursor at the lower rt hand corner of the screen and the 4 or 5 icons come out of the rt side of the screen - this is the settings menu.  When you click on the cog, these are not settings for the PC, it appears, since I'm in an app, these are the settings for this app ONLY.  Again, I'm a newbee and may be wrong.  I just wanted to share something that I just learned and found very helpful.  I am open to correction.

Message 8 of 11 (13,719 Views)
Novel Adventurer
Thank you, badboy-tinny! I thought I was going to have to pay some remote tech service.
Message 9 of 11 (7,806 Views)
Novel Tourist

My mic still isn't working and I've checked the permissions and it still isn't working

Message 10 of 11 (4,746 Views)
Discussion Stats
  • 10 replies
  • 6 kudos
  • 10 in conversation