By using this site you agree to the use of cookies for analytics, personalised content and ads. Read more

Windows 8- Webcam doesn't work!

This topic has been archived. To keep discussions in the Skype Community relevant we archive topics that haven't seen activity in the past 6 months. Read more about about archiving
Casual Tourist

I recently got a new computer that already had skype on it and everything (Windows 8) and every time I try to video call someone, it doesn't work. It pulls up the video for half a second and then is says "video off" even though it isn't off. My webcam isn't off, and I don't understand what to do. Does anyone else have this problem? Please help me, I really would love to skype with my brother who is deployed and who I hardly see. I want to see him.

P.S.- The sound works fine. That's the only thing that will work while skyping. 

Message 1 of 21 (10,714 Views)
20 Replies
Super Aviator

What type of Webcam?
Which version of Skype do you use?
Which laptop / tablet are you using?

Regards,
Tamim
__________________________________________________________________________________________
Location - Dhaka | Bangladesh - Standard Time Zone: GMT/UTC + 06:00 hour

If one of my replies has adequately addressed your issue, please click on the “Accept as Solution” button. If you found a post useful then please "Give Kudos" at the bottom of my post, so that this information can benefit others.
Message 2 of 21 (10,713 Views)
Novel Tourist

I have the same issue. I have a built-in webcam that came on my new Asus INtel i3 netbook. This came with Windows 8. All Skype tests run fine, and under options my video is turned on, it shows the video feed back to me in the little test image...my computer says nothing else is running my webcam. (That I can find.) I've followed all instructions suggested online to make sure the settings are proper. I've tried setting my video setting to "use default device" and also changing it to "USB2.0 HD Webcam," both of which should be the same, built in webcam, since I have no other. The video works with two contacts but not the other two? (I'm new, only have 4 contacts.) Not sure what else to do. What happens with these two contacts is that the sound is always fine, but there is automatically an "anti" symbol over the video button during calls, which when I click it, it goes away, shows my own video feed in the bottom right hand of the screen for a split second, (never their video) and then the "anti" symbol comes right back again over the video symbol...? My Sykpe version is new, although not sure exactly which version, but I just bought this laptop and it was built in with Windows 8. Any thoughts? I am trying to have long distance meetings and only the sound works. Very frustrating.

 

 

Message 3 of 21 (10,677 Views)
Community Ambassador

This is only one of possible reasons:

 

If your friends have in Tools -> Options -> Video settings selected the option “Automatically receive video and share screens with ..  no one”, then you will see exactly the described behaviour. You will not be able to turn your webcam on.

Message 4 of 21 (10,673 Views)
Casual Adventurer

I too am having problems in Windows 8 64 bit.  Cannot get the video to work.  Immediately crashes Windows if I try to change the settings.  Does reconise the video camera - as ET USB 2760 Camera.

 

Tried the changes above and immediately crashed.

 

Have uninstalled and reinstalled the software.  Have checkde I have latest window 8 desktop software.

 

Can anyone help please.

 

Derek

Message 5 of 21 (7,255 Views)
Super Aviator

derekjr,

 

You can uninstall current version of Skype from the control Panel and you can install Special Version.

http://www.skype.com/go/getskype-sse

and disable automatic updating of Skype.

In Skype, Tools >> Options >> Advanced >> Automatic updates >> Click on Turn off automatic updates >> Save Changes.

Regards,
Tamim
__________________________________________________________________________________________
Location - Dhaka | Bangladesh - Standard Time Zone: GMT/UTC + 06:00 hour

If one of my replies has adequately addressed your issue, please click on the “Accept as Solution” button. If you found a post useful then please "Give Kudos" at the bottom of my post, so that this information can benefit others.
Message 6 of 21 (7,220 Views)
Casual Adventurer

Tamin

 

I have tried this.  Removed the old version of Skype 6.6.  Loaded as per link.

 

The installation failed during the load with the following message:

 

"Installaing Skype failed:  code 1603

A fatal error occurred during installation"

 

Where do I go now? 

 

Derek

Message 7 of 21 (7,206 Views)
Super Aviator

derekjr,

 

Try this.

http://community.skype.com/t5/Windows-desktop-client/Upgrading-problem/m-p/1417756#M117090

Regards,
Tamim
__________________________________________________________________________________________
Location - Dhaka | Bangladesh - Standard Time Zone: GMT/UTC + 06:00 hour

If one of my replies has adequately addressed your issue, please click on the “Accept as Solution” button. If you found a post useful then please "Give Kudos" at the bottom of my post, so that this information can benefit others.
Message 8 of 21 (7,165 Views)
Casual Adventurer

Sorry no advance.  Just went through a reload and a serious crash again.  Then applied the Fix programme.  It did not detect any problems.

 

Looks like I will have to forget Skype on my PC.  The programmes supplied by Microsoft are not compatible with the Windows 8 operating system!!!

 

Give me Windows 7 back again and maybe I could have saved some money!!  n):

 

 

Derek

Message 9 of 21 (7,094 Views)
Super Aviator

Try below:

 

Download MSI Extractor
http://www.softpedia.com/progDownload/MSI-Extractor-Download-210862.html

 

Extract Skype Business Installer (SkypeSetup.MSI) with MSI Extractor.

http://www.skype.com/go/getskype-msi

 

Copy/Replace the Skype.exe file from the extracted folder to the phone folder under ProgramFiles\Skype directory.

 

Then right click on Skype.exe and select send to Desktop (Create shortcut)


Now try running skype using this new shortcut.

Regards,
Tamim
__________________________________________________________________________________________
Location - Dhaka | Bangladesh - Standard Time Zone: GMT/UTC + 06:00 hour

If one of my replies has adequately addressed your issue, please click on the “Accept as Solution” button. If you found a post useful then please "Give Kudos" at the bottom of my post, so that this information can benefit others.
Message 10 of 21 (7,091 Views)
Discussion Stats
  • 20 replies
  • 10715 views
  • 0 kudos
  • 5 in conversation