By using this site you agree to the use of cookies for analytics, personalised content and ads. Read more

On Windows 8 Skype Home screen just spinning

This topic has been archived. To keep discussions in the Skype Community relevant we archive topics that haven't seen activity in the past 6 months. Read more about about archiving
Novel Tourist

I have installed Skype for the desktop on my Windows 8 machine.  When opening Skyps I get a spinner instead of the Home screen.  I recently connected my Windows Live account, if that might have anything to do with it.


I have Nortons AV running but as suggested in other posts I have allowed Skype as an exception to the firewall... other suggestions?


Message 1 of 2 (738 Views)
1 Reply
Super Aviator

Try Below:


try deleting Skype from the list of permitted programs in Norton and adding it again.


Reset IE.


Press WinKey + R to open the Run window

WinKey (the button is located between the left Ctrl and Alt with the Windows logo)



Type: iexplore.exe and press Enter


In IE, Click Internet Options >> Advanced >> Restore Advanced Settings >> Reset.

Mark Delete personal settings >> OK >> restart.


Please Run the Cleaning Manager Utility


Press WinKey + R to open the Run window


type: cleanmgr tuneup and press Enter

select the Temp Internet Files boxes and click OK, then Click Delete files.


Now Check Proxy settings


In Internet Explorer, Go to, Tools >> Internet Options... >> Connections>> Lan settings , Use a proxy server... if it had been ticked, then... Remove that check. Make sure automatically detect settings is enabled. (Marked)


Location - Dhaka | Bangladesh - Standard Time Zone: GMT/UTC + 06:00 hour

If one of my replies has adequately addressed your issue, please click on the “Accept as Solution” button. If you found a post useful then please "Give Kudos" at the bottom of my post, so that this information can benefit others.
Message 2 of 2 (735 Views)
Discussion Stats
  • 1 reply
  • 0 kudos
  • 2 in conversation