By using this site you agree to the use of cookies for analytics, personalised content and ads. Read more

Can't share screens with Skype Windows 8

SOLVED
Go to Solution
This topic has been archived. To keep discussions in the Skype Community relevant we archive topics that haven't seen activity in the past 6 months. Read more about about archiving
Casual Tourist

Im on Windows 7 pro x64 Pro, Skype v. 6.11.0.102. I have the same problem:

When in a voice call, the Share screen option is disabled (grey).

Now Sharing screens used to work up to about a month ago, when Skype updated automatically.

Which version do I need to reverto to, to get it working again? 

Message 11 of 67 (15,960 Views)
Casual Adventurer

Do a search for the desktop version of Skype, and when you have it working like I have, don't let MS update it or you will be using the crappy windows 8 version wjhich looks very much like a beta version to me. They seem to be testing it on their customers. Shortly you will have to have a subscription to use what has always been free to most people.

Message 12 of 67 (15,949 Views)
Community Ambassador

BeumerE wrote:

Im on Windows 7 pro x64 Pro, Skype v. 6.11.0.102. I have the same problem:

When in a voice call, the Share screen option is disabled (grey).

Now Sharing screens used to work up to about a month ago, when Skype updated automatically.

Which version do I need to reverto to, to get it working again? 


Share screen option is enabled on any recent Skype desktop version. However, it’s only possible to share screen when on a call to another Skype client installed on a computer. If you are on a voice call to mobile or land line phone, then sharing screen is of course not possible.

Message 13 of 67 (15,946 Views)
Novel Tourist

Ruwim, you are right. Thanks a lot for your sharing. Even Help in Skype does not answer this issue.

Message 14 of 67 (15,896 Views)
Casual Adventurer

Not being able to view others share screen

My os is 8.1, I have installed the skype for desktop. I have also set, Video Settings==>Automatically receive video and share screens with anyone

 

Yet when my friend click on share screen, I cant view his screen, whilst if I click on share screen he could. My skype version=6.11.0.102. I have also click on updates and all is latest. I also set for automatic update

 

Able to block video calls but enable share screen


Pls advise how can I block all video calls yet able to allow anyone to share screen with me?

 

 

 

 

 

 

 

 

Message 15 of 67 (15,851 Views)
Novel Tourist

Except spell check! which is kind of big if you use it for work

Message 16 of 67 (15,836 Views)
Casual Adventurer

Skype can be frustrating. When I click on check updates it tells me that its the latest version. Later while searching around skype, I managed to find v6.11.60.102 (previously my version was v6.11.0.102)

 

I am not sure whether this will solve the issue I have to try it w my friend again! Anyone having same issues may search for this version, its last update was Nov 2013. Installed that and hopefully it shld work!

Message 17 of 67 (15,825 Views)
Casual Adventurer

[Except spell check!] May I know what you r referring to? Did i spell something wrongly?

Message 18 of 67 (15,824 Views)
Novel Adventurer

WNewquay wrote:

Please add support for screen sharing in Windows 8.1 version.
I'm running Surface (RT)  which is a great machine - but I REALLY need the screen sharing feature.

On Surface (RT) and Surface 2 - only Windows Store apps are supported. This rules out the desktop version.

 


I'm having the same problem on the Surface Win 8.1 RT.  I can only install microsoft store applications and don't have solution.

Message 19 of 67 (15,593 Views)
Novel Adventurer

I Have windows 8.1, and Im really not used to the built-in version, nor that you cant leave groups, and you cant share screens, is the desktop version safe to download? 

http://www.skype.com/en/download-skype/skype-for-windows/

Message 20 of 67 (15,351 Views)
Discussion Stats