By using this site you agree to the use of cookies for analytics, personalised content and ads. Read more

Can't download Skype from the WIndows 8 store

This topic has been archived. To keep discussions in the Skype Community relevant we archive topics that haven't seen activity in the past 6 months. Read more about about archiving
Casual Adventurer

I proceed from the "Get Skype for Windows 8" to "View in Windows Store", and when I click on the Install button, I get a message "Your purchase couldn't be completed" in large letters, and "something happened and your purchase can't be completed" underneath.

 

I have tried this repeatedly....help!!

24 Replies
Super Aviator

try this msaccounts troubleshooter

http://download.microsoft.com/download/F/2/4/F24D0C03-4181-4E5B-A23B-5C3A6B5974E3/microsoftaccounts....

Regards,
Tamim
__________________________________________________________________________________________
Location - Dhaka | Bangladesh - Standard Time Zone: GMT/UTC + 06:00 hour

If one of my replies has adequately addressed your issue, please click on the “Accept as Solution” button. If you found a post useful then please "Give Kudos" at the bottom of my post, so that this information can benefit others.
Message 2 of 25 (20,684 Views)
Casual Adventurer

Thank you for your response to my query.  I did down-load the troubleshooter, and the diagnostic that came back was "Turn on Synch for individual settings.  The following settings have synch turned off.  Personalization".

 

How do I do this, exactly?  I am new to W8, and I am not sure where this preference is located, and how to go about switching it on.

 

THank you for your help.

Message 3 of 25 (20,669 Views)
Super Aviator

Run the troubleshooter again and select Apply repairs automatically.

 

Regards,
Tamim
__________________________________________________________________________________________
Location - Dhaka | Bangladesh - Standard Time Zone: GMT/UTC + 06:00 hour

If one of my replies has adequately addressed your issue, please click on the “Accept as Solution” button. If you found a post useful then please "Give Kudos" at the bottom of my post, so that this information can benefit others.
Message 4 of 25 (20,664 Views)
Casual Adventurer
Tamim, thanks, but when I run the msaccounts troubleshooter, I do not have this box as an option to select. It runs through the routine, says that the issue has been Detected, but there is no instruction how to apply repairs

I am getting suspicious of the Norton that is pre-installed on the machine: I can't find how to disable this, either!
Message 5 of 25 (20,656 Views)
Casual Adventurer
update: ran the msaccount troubleshooter, found the "Apply Repairs Automatically" option (which I checked), then same result.

"Some settings have synch turned off" detected...but no advice how to turn them ON. Arrgh!
Message 6 of 25 (20,655 Views)
Super Aviator

Have you looked at the sync settings to make sure things are enabled?

 

WinKey + C >> Settings >> Sync your settings

 

Make sure Windows Firewall is turned on.

 

Press WinKey + R to open the Run window

WinKey (the button is located between the left Ctrl and Alt with the Windows logo)

 

 

type: services.msc /s, and press ENTER.

 

Look for the Windows Firewall, and then double-click on it and Start the service.

 

Regards,
Tamim
__________________________________________________________________________________________
Location - Dhaka | Bangladesh - Standard Time Zone: GMT/UTC + 06:00 hour

If one of my replies has adequately addressed your issue, please click on the “Accept as Solution” button. If you found a post useful then please "Give Kudos" at the bottom of my post, so that this information can benefit others.
Message 7 of 25 (20,653 Views)
Casual Adventurer
Thanks, but no good

"Windows can not find 'services.msc/s'. Make sure you typed the name correctly and try again."

This is a brand new Toshiba Sattelite running WIndows 8, BTW
Message 8 of 25 (20,646 Views)
Super Aviator

Please try again. There is a space after services.msc

 

services.msc /s

Regards,
Tamim
__________________________________________________________________________________________
Location - Dhaka | Bangladesh - Standard Time Zone: GMT/UTC + 06:00 hour

If one of my replies has adequately addressed your issue, please click on the “Accept as Solution” button. If you found a post useful then please "Give Kudos" at the bottom of my post, so that this information can benefit others.
Message 9 of 25 (20,644 Views)
Casual Adventurer
OK, I switched this setting to "Manual", and I still get the "Your purchase couldn't be completed" in large letters, and "something happened and your purchase can't be completed" underneath...please help
Message 10 of 25 (20,641 Views)
Discussion Stats
  • 24 replies
  • 20704 views
  • 6 kudos
  • 3 in conversation