By using this site you agree to the use of cookies for analytics, personalised content and ads. Read more

Skype doesn't ring with incoming calls

SOLVED
Go to solution
Novel Adventurer

Hi there, I'm on Skype 5.7.59.1037 which should be the latest mac release.
My MBP is running Lion which is completely updated as well.
I checked the notifications settings and everything looks properly set up, but for some unknown reason, when someone calls me I get no ringtone, all the other sounds work perfectly...
I also tried uninstalling skype using CleanMyMac (I believe it removed any file related to skype) and install it back from scratch, no change whatsoever...
Is someone experiencing the same? and more over any idea what could be the issue here? 
Thanks! 

  • Mac
1 Accepted Solution

Accepted Solutions
Staff Moderator

Is your status set to Do Not Disturb?

78 Replies
Casual Adventurer

am sure you have already tried this but if you have not then try the following.

 

go to preferences, then go to notification, and select sound releted to calls. also go to audio / video settings and select built in output in speakers and make the volume to max.

 

hope this helps.

Casual Tourist

I am having the same problem as Matita. All software is updated. When someone tries to call me, I do not get a ring. I get the notifications later, no set time. This has happened while I am using my computer, so I know it's not a sleep mode issue. The caller tells me when they call, it goes straight to voicemail. Any ideas?

Novel Tourist

Same problem and have tried the suggestions offered.  I am on iMac and the latest version.

 

When clicking on Skype>Preferences>Notifications the "Play Sound" box is ticked but is greyed out and not useable.

Moderator

Hi,

 

Did you check Mac System preferences >>> Hardware >>> Sounds >>> Sounds alerts also ?

* * * * * *
Il n'y a aucun problème que l'absence de solution ne puisse résoudre ! ;-)
IMac Intel 27" Retina Core i5 3.3 GHz - RAM 24 GB - OS 10.12.1 Sierra
Skype 7.42.200
Novel Tourist
Yes I have the same problem with sound effects after my recent upgrade. The 'play sound' section in my preferences is greyed out, and none of the above suggestions, or taking away configuration files has helped. Please Skype, fix this!
Casual Adventurer

This has been driving me crazy for a few months now (since upgrading from 2.8.x) and today I finally took the time to track it down. Like everyone else here:

 

  • Incoming calls produced no sound
  • In my "Notifications" preferences, the "Play sound" checkbox was unchecked and disabled (greyed out)

 

Here's what I did to fix the problem:

 

  • Open ~/Library/Preferences/com.skype.skype.plist in your favorite plist editor. For me, it opened in XCode by default, but it also opens fine in a text editor like TextWrangler. The plist file is just an XML text file at its core.
  • Find the option named "MuteAllAlertSounds".
  • Change the value from true/yes to false/no. If you're opening it in XCode, you'll change the "YES" value to "NO". If in a text editor, you'll change this...
	<key>MuteAllAlertSounds</key>
	<true/>

    to...

	<key>MuteAllAlertSounds</key>
	<false/>
  • Save your changes
  • Restart Skype

Now my "phone" actually rings and the "Play sound" checkbox is no longer disabled.

 

I hope that helps someone else.

Novel Tourist
Thank you so much, it worked perfectly.
Novel Tourist
Hey, i can't fint the file /Library/Preferences/com.skype.skype.plist. Skype is 5.7.0.1130, And is in Lion OSX 10.7.4

Thanks!