By using this site you agree to the use of cookies for analytics, personalised content and ads. Read more

my mac says, Can't create a lock file" when I clicked on skype in the applications folder

This topic has been archived. To keep discussions in the Skype Community relevant we archive topics that haven't seen activity in the past 6 months. Read more about about archiving
Novel Tourist
11 Replies

Hi there,


You probably don't have enough space on your HD for the application to start up.

Clean out a few files before trying again.



* * * * * *
Il n'y a aucun problème que l'absence de solution ne puisse résoudre ! ;-)
IMac Intel 27" Retina Core i5 3.3 GHz - RAM 24 GB - OS 10.12.3 Sierra
Skype 7.46.56758 & sur Android 4.2.2 à l'occasion. ;-)
Novel Tourist

Same problem.

OS 10.7.1, 61,63 GB available.


That should be enough.

Novel Tourist

same problem. I have tons of memory, so that's not the problem


Novel Tourist

How do you clean up a few files?

Novel Adventurer

I had this issue after I changed permissions on my mac.  Repairing permissions didn't help either.  What fixed it was the following:

1. locate your skype folder using finder (it should be under: ~your username/library/application support/)

2. create a new folder called skype_old

3. drag the whole skype folder into skype_old so that it is one level lower than it used to be

4. click on your skype icon to run skype.  It should bring up a first use screen, and in the background it will recreate the skype directory next to skype_old

5. close down skype

6. using finder, look inside skype_old/skype for the folder with your skype user name, and drag it into the new skype directory

7. restart skype and it should find your user name and let you log in.


If you have more than one skype user name, repeat steps 6 and 7.  This should get you going again. 

Novel Adventurer

I'm having the same error message. However I do not have the "skype folder" you mention in your directions above. The only skype files on my computer are the icon in the applications folder and the downloaded file that prompts me to drag that icon into the applications folder. Help!

Novel Adventurer

My guess is that you have used the search feature in Finder to locate your Skype files/folders.  This won't work.  Instead, in Finder, click on the folder that bears the name you gave the computer when you set it up, then click Go at the top of Finder, choose Go To Folder from the drop down list and then type in Library.  Under there will be Applications Support and Skype will be under that.  Alternatively, in Finder, click on the folder that bears the name you gave the computer when you set it up and you should then see folders such as Desktop, Documents, Downloads, Library etc.  Click on that Library folder and you'll be able to see Applications Support under it.  The Skype folder you want should be under that folder.

Community Ambassador

In Lion and Mountain Lion, the Skype folder is hidden.  You can reveal it from the Finder by clicking CMD-Shift-G.

Entia non sunt multiplicanda praeter necessitatem.
Novel Adventurer

Thanks. I do have lion, and I can search when I do CMD-Shift-G, but when I type in skype it says the folder cannot be found. Also, when I just go in through my library to applications support, there is nothing there either.

Discussion Stats
  • 11 replies
  • 2 kudos
  • 9 in conversation