By using this site you agree to the use of cookies for analytics, personalised content and ads. Read more

Wrong Phone Prefix to all my contacts + Deleting a phone number within a contact

This topic has been archived. To keep discussions in the Skype Community relevant we archive topics that haven't seen activity in the past 6 months. Read more about about archiving
Casual Tourist

I need to delete one of the phone numbers within a contact list under "Status". I did delete the whole contact info, but when I reinstall it by searching under " add Contact" it appears again all the inf that I deleted.

 

I'm having the problem also if I try to get any number from the list "Address Book", since automatically Skype has added my phone prefix to all (the ones within my country has double listed the prefix + the international ones has also my prefix) making all the list from address book worthless. To dial a number I have to do it by hand

 

I have a Mac OS X version 10.5.8 + Skype  version 5.7.0.1037.

 

Thanks for your help

Message 1 of 5 (899 Views)
4 Replies
Highlighted
Novel Tourist
I have the same issue and can not find a solution. I´ve just gone in to Skype preferences and turned off "Show Address Book Contacts". Then I created a new contact in Skype with the correct info. A hassle, yes, but I don´t have so many contacts to manage so...
Message 2 of 5 (859 Views)
Novel Adventurer
Me too any solutions thanks ; )
Message 3 of 5 (777 Views)
Novel Tourist

I too have a skype contact list with the wrong country code in front of the contact number.  Where the contact in my iMac contacts file has a country code included in it already, skype has added an additional (correct or incorrect) country code.  I need to make all my skype-to-phone-calls manually on the skype dial pad.

 

If anyone has a useful approach to dealing with this I would be grateful to  hear from you, as we all would.

Message 4 of 5 (738 Views)
Community Ambassador

Try this: In Skype's Calls preference panel, select "Select Country or Region" (the first item in the lengthy list of countries) rather than a a specific country.  Selecting a default country causes Skype to prefix telephones with +countrycode.  If your address book also includes country codes, you get extra digits.  Selecting NO country in Skype's preferences should solve the issue:

 

--
Entia non sunt multiplicanda praeter necessitatem.
Message 5 of 5 (736 Views)
Discussion Stats
  • 4 replies
  • 900 views
  • 0 kudos
  • 5 in conversation