By using this site you agree to the use of cookies for analytics, personalised content and ads. Read more

Why is Delete Contact grayed out in the menu????

This topic has been archived. To keep discussions in the Skype Community relevant we archive topics that haven't seen activity in the past 6 months. Read more about about archiving
Casual Adventurer

I am trying to delete a person I blocked and cannot find any way to do it.  What am I missing?  Note: they are not in my Address Book - they are people I don't know and don't want to know.  I block them and they keep appearing in my contacts as BLOCKED!!  I select Contacts in the Menu and nearly all options are grayed out including DELETE CONTACT.  Why??? What is the fix??

Message 1 of 8 (3,978 Views)
7 Replies
Community Ambassador
Since the blocked party isn't in your Contact list, you can't remove him/her from the list. This might work: UNBLOCK the party, then set your privacy preferences to only allow calls/video, etc., from your contacts. A restart may be necessary. Sorry I can't do better for you, as I don't receive unwanted calls, having set my privacy levels to prevent almost everyone from getting through. Yes, I'm antisocial.
--
Entia non sunt multiplicanda praeter necessitatem.
Message 2 of 8 (3,900 Views)
Honorary Adventurer

this is how i do it and it seems to work-after i select the contact that i want to delete/block u need to right click on mouse/touch pad and click on "remove from contacts" then (for some reason) after i do this i have to select the contact again 'cause it still is appearing in my contact list and after "double" clicking  on this name u will get an addl box asking to "BLOCK"this person/and/to REPORT ABUSE and then hit block-that seems to wrk and the name is then totally deleted-i hope i am making sense to u but that is how i delete contacts.  it is a( 2 )step process .I'll repeat;1.)select contact u want to delete 2.)right click on mouse/touch pad ,then hit remove fr contacts 3.)that does not remove the contact name though( it seems to me)-step#3 click again(maybe even "double"click on that same contact name) 4.)that brings up a "block"box /report abuse box asking u if u wish to block this person-hit yes. FINISHED!!!!name is removed fr contact list-atleast thats how it wrks for me-if there is an easier /other way i dont know.  and in my settings i do have "anyone can contact me/send me IM messages"-that setting i may change.

Message 3 of 8 (3,895 Views)
Casual Adventurer

You are BRILLIANT!!!!!  After months I have finally found something that works!  Yes - the trick is you can't just block them.  You have to ADD them as a contact first!!  Once you do that you THEN block them and they disappear!!!  YEA!!!  I love you!!!!

Message 4 of 8 (3,884 Views)
Honorary Adventurer

so glad that wrked for u-

Message 5 of 8 (3,878 Views)
Novel Adventurer

I had the same problem with unwanted requests so I just blocked them because delete was greyed out.  This is what worked for me: unblock the contact then block again by doing the procedure below (when you tick the box report abuse the blocked contact will dissappear) :

 

To block a contact and report abuse:

  1. Go to the Contacts or Recent tab, right-click the contact’s name and select Block This Person...
  2. In the message box, tick Report abuse if you wish to alert Skype of a nuisance contact.
  3. Click Block
Message 6 of 8 (3,565 Views)
Novel Adventurer

af4's explanation works.  Thank you for your detailed instructions.  These unsolicited contacts that I'd blocked but who were still appearing were driving me crazy.  Now they're gone.  Thanks again.

Message 7 of 8 (3,486 Views)
Novel Tourist

Thanks af4, should it really be that difficult to delete a contact??? what do you want for free right?

Message 8 of 8 (3,192 Views)
Discussion Stats
  • 7 replies
  • 3979 views
  • 1 kudo
  • 6 in conversation