By using this site you agree to the use of cookies for analytics, personalised content and ads. Read more

Skype 5.3 for Mac OS X requires Mac OS 10.5.8 or later ??

This topic has been archived. To keep discussions in the Skype Community relevant we archive topics that haven't seen activity in the past 6 months. Read more about about archiving
Casual Tourist

How come that You write Skype 5.3 for Mac OS X requires Mac OS 10.5.8 or later

when I download this file it's named Skype_5.3.59.1093.dmg

 

And Skype 5.3 for Mac OS X it doesn't work on my iMac power pc with 10.5.8

 

Wich is correct . Can it be used by my computer or not.

 

When I start Skype it says it cant be running this computer,

 

Yours Sincerely

 

Imelda Chavez / Anders Wikberg

info@acm-photo.se

 

anders.wikberg@telia.com

 

imelda.chavez@telia.com

Message 1 of 2 (2,155 Views)
1 Reply
Community Ambassador

The latest versions of Skype will NOT run on a PowerPC.  They require an Intel processor, no matter the version of the Mac operating system you are using.  That said, you can download older versions from oldapps.com/skype.php.

--
Entia non sunt multiplicanda praeter necessitatem.
Message 2 of 2 (2,048 Views)
Discussion Stats
  • 1 reply
  • 2156 views
  • 1 kudo
  • 2 in conversation