By using this site you agree to the use of cookies for analytics, personalised content and ads. Read more

Regarding My Skype Update,

This topic has been archived. To keep discussions in the Skype Community relevant we archive topics that haven't seen activity in the past 6 months. Read more about about archiving
Casual Adventurer

IT'S OFFICIALLY SAYING "Skype was unable to install the update because the old application can’t be overwritten." :mad:




Old application locked, maybe ?

You might try to unlock it (select and then hit ⌘I for showing Info) by clicking the tiny lock icon at bottom right.




* * * * * *
Il n'y a aucun problème que l'absence de solution ne puisse résoudre ! ;-)
IMac Intel 27" Retina Core i5 3.3 GHz - RAM 24 GB - OS 10.12.3 Sierra
Skype 7.46.56758 & sur Android 4.2.2 à l'occasion. ;-)
Former Ambassador

Or how about uninstalling Skype and then resintalling it?  That may clean out whatever is causing that problem.

Please note: I do not respond to requests for help via Private Message.
Novel Adventurer

I have the same problem.  It downloads, runs the install, then tells me the old application cannot be overwritten.  Someone said use the Command I, but that just opens up a new email message.

Novel Adventurer

I just ran into this problem. I think it is happening because I performed the last upgrade as a different user. Easy enough to fix if you are not scared of the terminal.


1. Open terminal

2. sudo bash    

    (enter password when prompted)

3. ls -l /Applications

    check which non root owns most apps (third column)

4. ls -ld /Applications/

    check which user owns the Skype app

5. If is not owned by the usual user then

    chown -R whateveruser /Applications/



I also have this problem. I listed the files in /Applications as you suggest, and they are owned by my normal non-root user, which seems correct to me. Any other ideas?

Novel Adventurer

My next step would probably have been to delete /Applications/, download a fresh copy and install.


Alternativly maybe chown -R root /Applications/ will encourage the Skype installer to try to escalate permissions to root to perform the install.


Just ideas, hopefully they will not cause your computer to explode but you never know :tongue:

This worked for me, and makes sense because I just migrated from my old MacBook to a new one.
Novel Tourist

I had the same problem. 


Exit skype, drag the application onto your desktop and click on it once and then click file, get info and click on the little locked icon so that there is no tick. Re-open skype and install the update and when you click reluach it will relauch the new version  


Hope this helped!

Novel Tourist

I did that and its unlocked. Still not allowing me to upgrade. This has been going on for months now and I cant figure it out. Have uninstalled, deleted, reinstalled, unlocked, locked, unlocked again.....and now my skype is acting up. 


I just uploaded Mountain Lion with hopes that this would sort itself out, no luck. 



Discussion Stats