By using this site you agree to the use of cookies for analytics, personalised content and ads. Read more

Skype Community has moved

You can find the new Skype Community here. For more information please read this post.

Pending Instant Messages

This topic has been archived. To keep discussions in the Skype Community relevant we archive topics that haven't seen activity in the past 6 months. Read more about about archiving
Novel Tourist

this really pisses me off.

Messages are "Pending" when I send a message to a contact who is offline (makes sense) . . .

 

...but when they come back online, the message will remain "Pending" for a few minutes... & then when it eventually sends, it will time-stamp itself to the time when I tried sending it (which is impossible because the contact was offline)

 

It's as if Skype doesn't want to "fess up" to when the message was actually sent (some time during the Pending process)

 

:mad:

 

 

Flag for a Moderator
Message 31 of 44
Novel Adventurer
I have same problem. All messages sent from my android note device show as "pending". It is synced with Skype on my laptop but these messages never send and never sync. As saved always show as pending until deleted. Only send when both online. Same for sms from skype on android - shows as sent but not delivered. Any ideas?
Flag for a Moderator
Message 32 of 44
Casual Tourist

I sent messages to a friend, pending contact request do they receive them and read them

Flag for a Moderator
Message 33 of 44
Novel Tourist

hi im sending a message but it wont let it just saying loading to send and he is online and he blocked me but i havent recived any of his messages what do i do 

Flag for a Moderator
Message 34 of 44
Novel Tourist
GUYS! I HAVE THE SOLUTION! (For iPad, idk for iPhones/Macs/Windows)

Uninstall Skype app (if being used) from iPad, then re-install it. Sign in with correct account.

You should now see more contacts online, and you should see times, not that stupid 'Pending' word in the top right screens. Some people may be viewed by usernames as opposed to real names, but you shouldn't be bothered by this. Have fun!
Flag for a Moderator
Message 35 of 44
Highlighted
Novel Tourist

For those of you still having this issue, the fix on Mac is to remove the messages stored on your drive. You can do this by following these steps.

 

  1. Close Skype
  2. Open a terminal (just use spotlight to find it).
  3. Type in (including the quotes): 
    cd "Library/Application Support"
  4. Type in: 
    rm -rf Skype/
  5. Start Skype

Edit: In order to alleviate some worries, this only removes the local copies of the messages and only temporarily. When you do this, as soon as you log back in to Skype it will take like 15 minutes where it repopulates all of the messages back again.

Flag for a Moderator
Message 36 of 44
Novel Adventurer

That worked perfectly! I had an account that people could Skype messages to individually and vice-versa, but it couldn't create group chats (they would all say pending), and it wouldn't receive messages when part of a group chat. But this fix did the trick. Thanks so much!

Tags (1)
Flag for a Moderator
Message 37 of 44
Novel Tourist
Hurry up and fix this crap, Microsoft own this junk now right? How about take away the M$ engineers and contract them out to people who know what they are doing.
Flag for a Moderator
Message 38 of 44
Novel Tourist

This problem still exists on Mac !

 

I'm using Skype 6.15 (33) which is apparently still the latest version.

 

 

The correct path is "~/Library/Application Support"

 

Note if you're using Finder: "Library" folder is hidden, so be sure  to show hidden files and folders.

 

then proceed to move "Skype" folder to trash and relaunch

 

 IMPORTANT: this will delete all "pending" messages, so before you do this you should copy and paste the pending messages to a text editor so that you can resend them with copy/paste instead of typing it all out again.

Flag for a Moderator
Message 39 of 44
Novel Tourist

DID NOT WORK FOR ME. Mac os X 10.6.8 Skype version 6.15.0.335

 

 

All messages pending... uninstalled etc. tried the terminal trick. 

 

I had to download version 5.8 to fix.

 

 

 

Flag for a Moderator
Message 40 of 44
Discussion Stats