By using this site you agree to the use of cookies for analytics, personalised content and ads. Read more

Non-intel Macs??

This topic has been archived. To keep discussions in the Skype Community relevant we archive topics that haven't seen activity in the past 6 months. Read more about about archiving
Novel Tourist

DSL has finally become available in my rural community!  I fired up skype 2.8 on my G5 Mac and it suggested there was an update.  Did the update only to find that it does not support my architecture.

 

Has Skype dropped support for the older non-intel macs running OSX 10.5.8?

Message 1 of 3 (846 Views)
2 Replies
Highlighted
Community Ambassador

The latest iterations of Skype (v5.x) require an Intel processor.  All is not lost, however.  Download v2.8 (or older versions) from oldapps.com/skype.php.  That should do it.  When you've installed it, disable the 'check for updates' option to avoid the problem in the future.

--
Entia non sunt multiplicanda praeter necessitatem.
Message 2 of 3 (843 Views)
Casual Adventurer

About a month ago my non Intel, PPC Mac stopped being able to video cam with Skype 2.8. Seems Sype does not want to answer this question.

Message 3 of 3 (351 Views)
Discussion Stats
  • 2 replies
  • 847 views
  • 0 kudos
  • 3 in conversation