By using this site you agree to the use of cookies for analytics, personalised content and ads. Read more

MacBook Pro Retina - camera no longer working on Skype

SOLVED
Go to Solution
This topic has been archived. To keep discussions in the Skype Community relevant we archive topics that haven't seen activity in the past 6 months. Read more about about archiving
Casual Adventurer

As of today my camera stopped working on Skype. When I start a video call I get the camera icon on the bottom with a fat red line through it.

In Skype Preferences under Audio/Video I can see camera in the selection menu ("FaceTime HD Camera (Built-in") but the video window beneath is black.

 

The camera works fine on PhotoBooth and on FaceTime.

 

I've even tried installing older versions of Skype, thinking it might be the newes update, but nothing works.

 

Any ideas?

Thanks!


See more topics labeled with:

Message 1 of 11 (15,649 Views)
1 Accepted Solution

Accepted Solutions
Casual Adventurer
Solution
Accepted by Claudius (Community Manager)
‎28-08-2015 11:00

The camera is working again!!!

I think I may have found the problem. It could have been the Address Book. I had been updating some photos for contacts and since that feature also lets you access the camera to take a pic of yourself for your own contact info (because I might forget what I look like and then at least Address Book can remind me!) that may have blocked the camera. 

Be that as it may, I have my camera back!

Thanks for your time!

View solution in original post

Message 4 of 11 (16,400 Views)
10 Replies
Honorary Adventurer
Close all three programmes, PhotoBooth, FaceTime and Skype. Restart Skype only and you should have your video back. Both FaceTime and PhotoBooth hog the video and Skype doesn't get a look in if they're running beside it.
Message 2 of 11 (15,625 Views)
Casual Adventurer

Thanks for the feedback. Sadly, neither FaceTime nor Photobooth were actually running when the the problem occurred. I've also reinstalled Skype (having also deleted all the settings files in Library) and started up from scratch (again without FaceTime or PhotoBooth) and the camera is still not being activated. So I hope there's something else I could try...

Message 3 of 11 (15,612 Views)
Casual Adventurer
Solution
Accepted by Claudius (Community Manager)
‎28-08-2015 11:00

The camera is working again!!!

I think I may have found the problem. It could have been the Address Book. I had been updating some photos for contacts and since that feature also lets you access the camera to take a pic of yourself for your own contact info (because I might forget what I look like and then at least Address Book can remind me!) that may have blocked the camera. 

Be that as it may, I have my camera back!

Thanks for your time!

Message 4 of 11 (16,401 Views)
Novel Tourist

I have the exact same problem, but I cannot fix it!  Help!

Message 5 of 11 (14,006 Views)
Honorary Adventurer

That's a new one, well caught! :-)


Oilbert wrote:

The camera is working again!!!

I think I may have found the problem. It could have been the Address Book. I had been updating some photos for contacts and since that feature also lets you access the camera to take a pic of yourself for your own contact info (because I might forget what I look like and then at least Address Book can remind me!) that may have blocked the camera. 

Be that as it may, I have my camera back!

Thanks for your time!


 

Message 6 of 11 (13,987 Views)
Routine Adventurer

This from a fellow traveller on another strand:

 

Try this: open ichat and go to preferences, Audio/Video and unclick "automatically open ichat when external camera is turned on". Quit ichat, quit and restart skype.

 

Skype really should make this easier to find. I found it in the forum, the guy who offered it had found it on a Chinese forum. And Skype really should monitor the community and offer help rather than letting people flounder

Message 7 of 11 (10,887 Views)
Novel Tourist

For those of you running VMWare Fusion on your Mac beware that your VMs will connect to your camera by default when they start up. Once your VM starts, no more Facetime, Skype, etc.

I am a developer and run a few Windows VMs on my Mac.

 

To avoid this, look in the settings of each of your VMs under "USB & Bluetooth". Make sure the "Apple FaceTime HD Camera (Built-in)" is disconnected. As soon as you do this, your camera will be released and you can use it again.

Message 8 of 11 (10,764 Views)
Tourist

To Martinakeeley,

 

Brilliant! Going to ichat and following your instructions worked right away.  I agree that Skype should make this information available to its users.  Thank you for your help!

Message 9 of 11 (8,984 Views)
Novel Tourist

For those of you running VMWare Fusion on your Mac beware that your VMs will connect to your camera by default when they start up. Once your VM starts, no more Facetime, Skype, etc.

I am a developer and run a few Windows VMs on my Mac.

 

To avoid this, look in the settings of each of your VMs under "USB & Bluetooth". Make sure the "Apple FaceTime HD Camera (Built-in)" is disconnected. As soon as you do this, your camera will be released and you can use it again.

 


this fixed me up !!!!

Message 10 of 11 (8,052 Views)
Discussion Stats
  • 10 replies
  • 15650 views
  • 5 kudos
  • 8 in conversation