By using this site you agree to the use of cookies for analytics, personalised content and ads. Read more

video is not working on Ubuntu 11.10

This topic has been archived. To keep discussions in the Skype Community relevant we archive topics that haven't seen activity in the past 6 months. Read more about about archiving
Novel Adventurer

I get the following error:

 

ERROR: ld.so: object '/usr/lib/i386-linux-gnu/libv4l/v4l1compat.so' from LD_PRELOAD cannot be preloaded: ignored.


Message 11 of 31 (10,377 Views)
Routine Adventurer

I'm running 10.10, had to reinstall because of a bad hard drive. Now skype refuses to see my video (cheese works fine). I'm using a capture card and it sees that (video1). It used to work just fine (old version?).

LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so /usr/bin/skype "$@"   starts up skype but still no video.

Message 12 of 31 (10,312 Views)
Routine Adventurer
Oh, my sip client works great, but there's nobody to call because they're all on skype. sip:vandamme@ekiga.net.
Message 13 of 31 (10,311 Views)
Novel Adventurer

I've got the same error. before I used ubuntu 10.10 ans with this line it worked. cheese working with no problem . and this bug exist form 9.04 . no body care . 

Message 14 of 31 (10,154 Views)
Novel Adventurer

As seen on Ubuntu forums, and worked for me just now...


LD_PRELOAD=/usr/lib/i386-linux-gnu/libv4l/v4l1compat.so skype

 

This command will work only if you have 32-bit Oneiric installed. For 64-bit you must first:

sudo apt-get install libv4l-0:i386

 

...in order to obtain required 32-bit version of v4l1compat.so - then it works.

 

Pre-loading the 64-bit version does not work - you need the 32-bit version.

Message 15 of 31 (10,010 Views)

Thanks, this solution worked for me! But why do we sometimes after going through an upgrade face these issues? Aaarrghh!

Message 16 of 31 (9,982 Views)
Z37
Novel Tourist
I found solution!
If you got this ERROR: ld.so: object '/usr/lib/i386-linux-gnu/libv4l/v4l1compat.so' from LD_PRELOAD cannot be preloaded: ignored.

just do this:
LD_PRELOAD=/usr/lib32/libv4l/v4l1compat.so skype
THIS IS FOR 64BIT SYSTEMS!
Message 17 of 31 (9,666 Views)
Novel Tourist

Works for me to on Sony VGN FJ 200 laptop, tnx

 

Message 18 of 31 (9,470 Views)
Casual Tourist

Hi,

 

I have no idea how to edit the Startup Applications or the Main Menu item for Skype in Ubuntu (I am using 11.10 64bit version), but there is simply workaround.

Skype entry in the Startup Applications or the Main Menu points to binary file /usr/bin/skype, so it is enough to modify this binary file in order to add needed startup parameter:

 

LD_PRELOAD=/usr/lib32/libv4l/v4l1compat.so

 

(You can use your version of LD_PRELOAD parameter: LD_PRELOAD=/usr/lib/i386-linux-gnu/libv4l/v4l1compat.so)

 

To do this perform following steps:

 

1. Rename original binary skype file:

 

sudo mv /usr/bin/skype /usr/bin/oldskype

 

2. Write following bash script and store it in file named skype:

 

#!/bin/bash

LD_PRELOAD=/usr/lib32/libv4l/v4l1compat.so oldskype

 

3. Add executive property to newly created file:

 

chmod +x skype

 

4. Copy script skype to /usr/bin

 

sudo cp skype /usr/bin

 

That's all :-), next when you run skype from Main Menu or just from console by typing skype the LD_PRELOAD parameter will be automatically added and video will be avialable.

 

BR,

 

esso

 

Message 19 of 31 (9,263 Views)
Novel Adventurer
I installed the previous version of skype and now everything works great! I use ubuntu 11.10! I have a small problem thought! How can i make skype not update to the new version?!
Smile....
Message 20 of 31 (9,255 Views)
Discussion Stats