By using this site you agree to the use of cookies for analytics, personalised content and ads. Read more

video is not working on Ubuntu 11.10

This topic has been archived. To keep discussions in the Skype Community relevant we archive topics that haven't seen activity in the past 6 months. Read more about about archiving
Casual Adventurer

The skype audio is working well but there is no video as of the update from 11.04 to 11.10.

To make it work under 11.04 I had to use

 

LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so /usr/bin/skype "$@"



I had a look in /usr/lib and there is no longer any libv4l directory. Apparently it is no longer compatible and thus has been removed. Likewise there is no v4l1compat in synaptic, probably for the same reason.

 

The question is: do I have any hope of using video in 11.10? (The program Cheeze works perfectly, so the hardware is working.)

 

Thanks,

Ilan

Message 1 of 31 (21,779 Views)
30 Replies
Casual Tourist

I'm using Ubuntu 11.10 32-bit.

I changed the starter's command line to this:

 

sh -c 'LD_PRELOAD=/usr/lib/i386-linux-gnu/libv4l/v4l1compat.so /usr/bin/skype "$@"'

 

Haven't tried calling anyone yet, but testing my webcam in options has me looking at my own mug. Cheers, Arjen

Casual Tourist

Hello,

I'm also using ubuntu 11.10 and was having problems with the video not working.  I used the command " sh -c 'LD_PRELOAD=/usr/lib/i386-linux-gnu/libv4l/v4l1com

pat.so /usr/bin/skype "$@"' " in terminal and the video worked no problem.  I'm still a bit of a newbie so what file can I add this line to and not have to use terminal every time I want to start Skype.  Thanks for all your help.

Message 3 of 31 (21,375 Views)
Casual Adventurer

Thanks. That works from the command line (incidentally, I did not need this on my Asus EEE PC Netbook), and that's fine for me. But other users (like my spouse) will look at me quizzically if I expect them to open a terminal and either log in as root or type sudo and then:

sh -c 'LD_PRELOAD=/usr/lib/i386-linux-gnu/libv4l/v4l1compat.so /usr/bin/skype "$@"'

 

So the question is how do I set up the Startup Applications or the Main Menu item for Skype to execute this command when not in a shell?

 

Thanks all you helpful people.

Message 4 of 31 (21,210 Views)
Casual Adventurer

That command seems to work in the launcher. I have not  tried it in Startup Applications yet.

Message 5 of 31 (21,189 Views)
Routine Adventurer

I tried those preload commands in Ubuntu 10.10 and nothing worked ("cannot be preloaded").

Message 6 of 31 (21,058 Views)
Novel Adventurer

I'm still using Ubuntu 10.04 LTS - when I just tried the preload command I also got the error message "OAD cannot be preloaded: ignored".

Message 7 of 31 (21,056 Views)
Novel Adventurer

Hi --Name is Bob --Very new on this (just started trying Ubuntu 2 days ago)-but have  used skype 2 years on Win XP pro

 

Am having the same problem with skype--video not being acknowledged by it on Ubuntu 11.10--is this ever to be fixed???--and yes CHEESE is working OK

 

I am also very old and do not know a thing about fixing things --unless given step by step instructions --any help would be appreciated --Thanks for reading

Message 8 of 31 (20,668 Views)
Novel Adventurer

I'm having the same problem. Have tried all the suggested remedies. Nothing works.

 

My webcam video and audio both work in Cheese.

 

I am using Ubuntu 11.10 64-bit.

Message 9 of 31 (20,611 Views)
Novel Adventurer
I get the error:

ERROR: ld.so: object '/usr/lib/i386-linux-gnu/libv4l/v4l1compat.so' from LD_PRELOAD cannot be preloaded: ignored.
Message 10 of 31 (20,609 Views)
Discussion Stats