By using this site you agree to the use of cookies for analytics, personalised content and ads. Read more

crackling sound in Debian Sid 64bit

This topic has been archived. To keep discussions in the Skype Community relevant we archive topics that haven't seen activity in the past 6 months. Read more about about archiving
Highlighted
Tourist

In current Debian Sid / Wheezy, Skype sound output through pulseaudio is crackling and audio input is outright atrocious, i.e. crackling in the extreme. All other sound applications work just fine.

 

At the same time, sound in Debian Squeeze is ok and to my surprise, it also works well in current Ubuntu. So there must be some specific reason why Skype misbehaves on Sid / Wheezy.

 

My ~/.asoundrc goes:

 

pcm.!default {
    type pulse
}
ctl.!default {
    type pulse
}


So Skype uses pulseaudio, however, the result is very disappointing...

Message 1 of 3 (4,000 Views)
2 Replies
Novel Adventurer
I am having a similar problem and the last version not to cause the problem on both Linux mint 12 and debian testing for me is 2.1.0.81
Message 2 of 3 (3,576 Views)
Novel Adventurer

I have just followed the guidance for the first fix on this page and the sound now sounds great.

 

http://www.pc-freak.net/blog/how-to-fix-pulseaudio-and-skype-crappy-sound-glitches-choppy-sound-and-crackling-on-debian-gnu-linux/

 

In summary

 

In file/etc/pulse/default.pa its necessary to substitute the line;

load-module module-udev-detect

 

with

 

load-module module-udev-detect tsched=0

Message 3 of 3 (3,568 Views)
Discussion Stats
  • 2 replies
  • 4001 views
  • 4 kudos
  • 2 in conversation