By using this site you agree to the use of cookies for analytics, personalised content and ads. Read more

Ubuntu 14.04 / Skype 4.3.0.37 audio input not working

This topic has been archived. To keep discussions in the Skype Community relevant we archive topics that haven't seen activity in the past 6 months. Read more about about archiving
Novel Tourist

I can't get audio input to work on Ubuntu 14.04 with Skype 4.3.0.37. All settings are ok, I have verified with pavucontrol, mic is working fine in all other applications. Any ideas?

5 Replies
Novel Adventurer

the following thing worked for me:

 

sudo apt-get install pavucontrol

 

that will  also install pulseaudio server which will provide the virtual device for skype. If that still does not work, go to skype "sound devices" settings and launch "Open pulseaudio volume control". There ou can check which input/ouput devices are on/off and set the right thing for you.

Message 2 of 6 (28,774 Views)
Highlighted
Novel Adventurer

I'm having the same problem. When I select Options/Sound Devices in Skype, there is only one option in the dropdown menus for Microphone and Speakers: "Virtual Device." See the screenshot:

I have PulseAudio Volume Control-- it seems that skype isn't recognizing that.  Audio, mics, speakers work fine on all other applications.

Message 3 of 6 (28,559 Views)
Novel Adventurer

I had the "virtual device" thing before I installed pulseaudio. Now it says "pulseaudio server (local)". Could it be that pulseaudio server is not installed (that would be strange however, since you have pavucontrol) ? Try to reinstall pulseaudio:

 

sudo apt-get install --reinstall pulseaudio pavicontrol

 

The fact that sound/mic is working in all other apps does not mean that pulseaudio is installed, because all other apps use another sound server. Pulseaudio is a requirement by microsoft, and it is only required by skype as far as I know.

Message 4 of 6 (28,497 Views)
Novel Adventurer

I tried that... Skype still gives me the same options.  And now, when I open pavucontrol, I see this:

 

What to do?

Message 5 of 6 (28,472 Views)
Novel Adventurer

Hi, I am sorry to propose you again the same thing, but it really seems like you pulseaudio server is not configured correctly. So, I suggest removing the pulseaudio server together with its configuration like so

 

sudo apt-get remove --purge pulseaudio

 

Then check that config files in  /etc/pulseaudio/* do not exist, if they do, remove them.

Then remove local config directories: probably ".config/pulse" and maybe also ".pulse" from your home directory.

 

then run again

 

sudo apt-get install pulseaudio

 

That is all I can suggest. Configuring pulseaudio manually is not my cup of tea.

 

(You might also try to remove skype with  its configuration files,

  sudo apt-get remove --purge skype

  rm -r .config/Skype

  rm -r .Skype

and then reinstall skype. Beware that removing Skype config will also remove your skype log files)

Discussion Stats
  • 5 replies
  • 29135 views
  • 7 kudos
  • 3 in conversation