By using this site you agree to the use of cookies for analytics, personalised content and ads. Read more

Ubuntu 12.10 and Skype 4.1 fails during launch

This topic has been archived. To keep discussions in the Skype Community relevant we archive topics that haven't seen activity in the past 6 months. Read more about about archiving
Novel Adventurer

I have Ubuntu 12.10 x86_64 desktop installed and fully updated. I've installed Skype 4.1.0.20 using the multiarch package. When I click on the Skype icon, nothing happens. So, I've tried running it from a terminal and I get the following output:

 

$ skype
Gtk-Message: Failed to load module "overlay-scrollbar"
`menu_proxy_module_load': skype: undefined symbol: menu_proxy_module_load

(skype:4274): Gtk-WARNING **: Failed to load type module: (null)

`menu_proxy_module_load': skype: undefined symbol: menu_proxy_module_load

(skype:4274): Gtk-WARNING **: Failed to load type module: (null)

`menu_proxy_module_load': skype: undefined symbol: menu_proxy_module_load

(skype:4274): Gtk-WARNING **: Failed to load type module: (null)

`menu_proxy_module_load': skype: undefined symbol: menu_proxy_module_load

(skype:4274): Gtk-WARNING **: Failed to load type module: (null)

skype: symbol lookup error: skype: undefined symbol: _ZN17QSslConfiguration12setSslOptionEN4QSsl9SslOptionEb

 

I have searched all over the web and cannot find any explanation for this failure. Please help!

Message 1 of 10 (4,346 Views)
9 Replies
Novel Adventurer

Any suggestions here? I've been working on this problem for hours and have had absolutely no luck.

Message 2 of 10 (4,280 Views)
Routine Adventurer

I am also using Ubuntu but i downloaded the Skype software from the Skype home site and have not had any probem so far?

 

I would suggest you remove the version you downloaded via synaptic and visit the Skype site itself and download from there!

Message 3 of 10 (4,221 Views)
Novel Tourist

Downloaded from the website and the same problem here.

 

I'm using Ubuntu 13.04 64-bit.

Message 4 of 10 (2,899 Views)
Novel Tourist

I'm also Having the same issue for the last one week. I think, for me, the issue is started after a regular Ubuntu (13.04) update last week. Any Help is much appretiated.

 

Message 5 of 10 (2,694 Views)
Highlighted
Casual Tourist

Me too I am having the problem starting this morning.

 

skype
Gtk-Message: Failed to load module "overlay-scrollbar"
`menu_proxy_module_load': skype: undefined symbol: menu_proxy_module_load

(skype:14205): Gtk-WARNING **: Failed to load type module: (null)

`menu_proxy_module_load': skype: undefined symbol: menu_proxy_module_load

(skype:14205): Gtk-WARNING **: Failed to load type module: (null)

`menu_proxy_module_load': skype: undefined symbol: menu_proxy_module_load

(skype:14205): Gtk-WARNING **: Failed to load type module: (null)

`menu_proxy_module_load': skype: undefined symbol: menu_proxy_module_load

(skype:14205): Gtk-WARNING **: Failed to load type module: (null)

 

Can someone investigate what's going on here?

 

Thanks

Message 6 of 10 (2,561 Views)
Tourist

I had the same problem.  In the end, I had to open System Monitor, find the skype process and try to stop it.  Just "stopping" or "ending" didn't work, but "killing" it worked.  Afterwards I could load Skype as if there was never any problem.

Message 7 of 10 (2,286 Views)
Novel Tourist

killall skype via the terminal does not work for me either - I also had to go into the System Monitor and kill the process there. I'm on Ubuntu 12.04 LTS, but with latest kernels. Skype wouldn't start for me either after an Ubuntu update today. Probably unrelated. Above actions solved my woes.

Message 8 of 10 (1,989 Views)
Novel Adventurer

try this

sudo apt-get install appmenu-gtk:i386

and

sudo apt-get install appmenu-gtk

Message 9 of 10 (1,679 Views)
Novel Adventurer

Solved:

 

Ubuntu 12.04.4 LTS x64

 

In the beginning I got:

kestutis@kestutis-i3:~$ skype
`menu_proxy_module_load': skype: undefined symbol: menu_proxy_module_load

(skype:5860): Gtk-WARNING **: Failed to load type module: (null)

`menu_proxy_module_load': skype: undefined symbol: menu_proxy_module_load

(skype:5860): Gtk-WARNING **: Failed to load type module: (null)

`menu_proxy_module_load': skype: undefined symbol: menu_proxy_module_load

(skype:5860): Gtk-WARNING **: Failed to load type module: (null)

`menu_proxy_module_load': skype: undefined symbol: menu_proxy_module_load

(skype:5860): Gtk-WARNING **: Failed to load type module: (null)

 

After intalling "sudo apt-get install appmenu-gtk:i386".

"sudo apt-get install appmenu-gtk" was already in newest version.

I got just:

kestutis@kestutis-i3:~$ skype
Nutraukta (aborted) (core dumped)

 

But then:

I fixed with this query executing on main.db (./sqlite3 ~/.Skype/[Removed for privacy]/main.db):

http://community.skype.com/t5/Linux/Skype-4-3-crashes-with-old-chat-history/m-p/3369429#M9430

I downloaded newest SQLite version 3.8.5 and then executed that UPDATE query Because my SQLite in Ubuntu 12.04.4 LTS x64 didn't support instr:

2012-12-12 (3.7.15)

Added the instr() SQL function.

Because default version in the distribution (Ubuntu 12.04.4 LTS x64) version was:

sqlite3 -version
3.7.9 2011-11-01 00:52:41 c7c6050ef060877ebe77b41d959e9df13f8c9b5e

 

Message 10 of 10 (1,405 Views)
Discussion Stats
  • 9 replies
  • 4347 views
  • 1 kudo
  • 9 in conversation