By using this site you agree to the use of cookies for analytics, personalised content and ads. Read more

Sound in Debian unstable 64bit broken?

This topic has been archived. To keep discussions in the Skype Community relevant we archive topics that haven't seen activity in the past 6 months. Read more about about archiving
Casual Adventurer

Recently skype stopped working in Debian unstable amd64. It is silent or makes high-pitch buzz. In 64 bit applications such as mplayer sound works

Message 1 of 9 (5,519 Views)
8 Replies
Casual Adventurer

Update -with pulseaudio removed skype works.

Message 2 of 9 (5,504 Views)
Casual Adventurer

Update 2 - after downgrading PulseAudio from 4.0 to 2.0 sound works. With PulseAudio 4.0 all of skype 4.2, 4.1, 4.0 are broken

Message 3 of 9 (5,438 Views)
Highlighted
Casual Adventurer

more update - running skype with PULSE_LATENCY_MSEC=30 skype (as suggested at https://bugs.archlinux.org/task/35690 ) makes calls work, (with PulseAudio 4.0 and skype 4.2) but notification sound are not played

Message 4 of 9 (5,433 Views)
Former Staff

Yes, Skype has problems with PulseAudio 3.x and 4.x we are aware of that and we are working to have a fix.

Message 5 of 9 (5,415 Views)
Novel Adventurer

any update on resolving the issue with pulseaudio 4.x?

Message 6 of 9 (4,201 Views)
Casual Adventurer

Setting environment variable PULSE_LATENCY_MSEC=30 helps.

Message 7 of 9 (4,188 Views)
Novel Adventurer

I read about the fix earlier in the thread. Thanks anyway for the reply.

What I was asking if there is any progress on fixing the root cause so no workaround is necessary.

 

Message 8 of 9 (4,166 Views)
Novel Tourist

So, seems like no progress on this?


If you ever release a new version with pulseaudio > 2 support please make it also work with pulse >5 because that's what is now in debian testing/unstable.

 

Yours

Message 9 of 9 (2,186 Views)
Discussion Stats
  • 8 replies
  • 5520 views
  • 4 kudos
  • 4 in conversation