By using this site you agree to the use of cookies for analytics, personalised content and ads. Read more

Solution for not working microphone under Ubuntu 11.10

SOLVED
Go to Solution
This topic has been archived. To keep discussions in the Skype Community relevant we archive topics that haven't seen activity in the past 6 months. Read more about about archiving
Casual Tourist

I have Linux Mint 13 on my laptop system.  I know how to get to Terminal, but have never used it. 

 

Can you give a complete step-by-step on how to do the above fix for my microphone?  I don't know how or where to insert the code you mention. 

Message 11 of 18 (13,255 Views)
Novel Adventurer

When I downloaded the latest version of skype I found that my microphone wasn't working.  When i investigated audio settings I found that the microphone setting had changed to 'externai mic' so I altered that back to 'internal mic' and Hey Presto, it was working again!!  Hope this is helpful.   Susan

Message 12 of 18 (13,212 Views)
Novel Adventurer

Careful. Issuing this killall pulseaudio in Ubuntu 12.4 has now removed ALL my sound hardware list in my Sound Settings. I have no sound or microphone now... :-(

Message 13 of 18 (11,817 Views)
Novel Adventurer

Reinstated by issuing

 

$ sudo mv ~/.pulse ~/.pulse.old

 


Phew! ;-)

 

Message 14 of 18 (11,814 Views)
Novel Tourist

Worked for me on Kubuntu 12.10 -  wow a month of it not working and it was a skype config issue - thanks finallyt solved.

 

Message 15 of 18 (9,679 Views)
Casual Adventurer

Ubuntu 13.04 x64. Kernel: 3.8.0-32-generic. Notebook: Lenovo Ideapad Z580A.

After updating to 4.2.0.11 the microphone is lost! All other features work normally.

I try the version from Skype download - the result is the same! Sound settings in Skype are unchangable.

I test my microphone with Audacity. It works normally!

Starting Skype in terminal causes backtrace:

================================================================

:~$ skype
Gtk-Message: Failed to load module "overlay-scrollbar"
`menu_proxy_module_load': skype: undefined symbol: menu_proxy_module_load

(skype:4371): Gtk-WARNING **: Failed to load type module: (null)

`menu_proxy_module_load': skype: undefined symbol: menu_proxy_module_load

(skype:4371): Gtk-WARNING **: Failed to load type module: (null)

`menu_proxy_module_load': skype: undefined symbol: menu_proxy_module_load

(skype:4371): Gtk-WARNING **: Failed to load type module: (null)

`menu_proxy_module_load': skype: undefined symbol: menu_proxy_module_load

(skype:4371): Gtk-WARNING **: Failed to load type module: (null)
=================================================================

After this login screen is apeared. And no enother messages in terminal.

 

B.R. Viktor.

 

Casual Adventurer
For me the problem is solved using solution in http://ubuntuforums.org/showthread.php?t=801643 1. Install pavucontrol PulseAudio Volume Control by sudo apt-get install pavucontrol 2. Run pavucontrol and select microphone as default input. If required tune mic. level. 3. Perform Skype calls. It works.
Message 17 of 18 (8,814 Views)
Novel Tourist

скачай и установи gnome alsa mixer и тогда микрофон будет работать. не забудь проверить настройки

Message 18 of 18 (8,306 Views)
Discussion Stats
  • 17 replies
  • 101156 views
  • 15 kudos
  • 14 in conversation