By using this site you agree to the use of cookies for analytics, personalised content and ads. Read more

Skype for Redhat Enterprise 6

This topic has been archived. To keep discussions in the Skype Community relevant we archive topics that haven't seen activity in the past 6 months. Read more about about archiving
Casual Tourist

We have a large deployment of RHEL 6 Clients in place. Skype 4.0 worked fine (with the static version and some library tweaks). Since the 4.1 does not come as a static build anymore there seems to be no way to use Skype in an enterprise Linux environment.

 

Please provide a build for RHEL 6 (or Centos, or Scientific Linux). Do not let the enterprise linux customers (yes, we have a lot of paying accounts) standing in the rain please.

See more topics labeled with:

Message 1 of 44 (27,799 Views)
43 Replies
Novel Adventurer

Definitely need something that runs on RHEL6 and variants.

 

The F16 RPM won't install because it requires:

 

alsa-lib >= 1.0.23 (only 1.0.22 is available)

libstdc++.so.6(GLIBCXX_3.4.15)

 

The dynamic version crashes with the message "Illegal instruction (core dumped)" on the command line. dmesg shows:
skype[10062] trap invalid opcode ip:807c238 sp:ff8edcfc error:0 in skype[8048000+1b5c000]

 

Some googling seems to indicate that the skype binary was likely compiled with sse3 instructions or something that RHEL6 doesn't support.

rgo
Casual Adventurer

The Ubuntu 10 skype binary should be compatible with EL6. Extract it from the deb file and and then put it in the "dynamic" version. That probably works.

 

Edit: No, doesn't work. All dependencies are fullfilled as expected. But it dies immeadiately with a segfault (Null pointer dereferenced.)

 

Normally, I would say that a programm that is binary-only but does not have a version for RHEL cannot be worth a thing.

Message 3 of 44 (27,655 Views)
rgo
Casual Adventurer

Ok, here's the "solution":

 

1) Install the "dynamic" version.

 

2) Replace the skype binary with the one from the Ubuntu 10 package.

 

3) Get libQtWebKit.so.4 from some old qt package for el6 and make skype use it via LD_LIBRARY_PATH or whatever.

 

Correction: It was absent in el6 from the very beginning. I got my version somehow else. 4.6.2-15 from fc12 should do the trick, too.

 

 

 

Rationale:

 

ad 2) Ubuntu 10 is extremely close to EL6, that binary simply must and really does work.

 

ad 3) RH dropped QtWebKit in EL6 after originally having it. It's now supplied by epel, but derived from other sources, hence the segfault.

 

Optional and final step: Look for an alternative to skype if they don't offer a RHEL package in the near future, because after their support for Ubuntu 10 ends, there won't be any tricks anymore. (Did you know? Ubuntu and Skype are partners ...)

 

Message 4 of 44 (27,642 Views)
rgo
Casual Adventurer

I wanted to put it all in the thread above, but editing time is now over.

 

The best source for libQtWebKit.so.4 is most probably Ubuntu 10. If someone has a link to the deb file, please post.

 

Perhaps we even can come up with a clear step-by-step description. Which in turn should be somewhere else (CentOS Forum or so).

 

[I'm still very much puzzeled about Skype: Are they really _that_ stupid or are they doing this on purpose? How can I offer a binary-only program without having a package for RHEL? Where do these people live?]

Message 5 of 44 (27,618 Views)
Experienced Adventurer

http://packages.debian.org/wheezy/libqtwebkit4

 

... choice "architecture" at bottom of page and download from near to you mirror.

Message 6 of 44 (27,601 Views)
Novel Tourist
CentOS has a wiki article about how to install skype:

http://wiki.centos.org/HowTos/Skype
Message 7 of 44 (27,591 Views)
rgo
Casual Adventurer

That was yesterday. With 4.1, there's no binary that works ootb.

 

Please calm down. Read at least what has been said so far. "Quick replies" are not needed.

 

If you want to really help, please post a link to the latest deb (32 bit) in Ubuntu 10 LTS that includes the file "libQtWebKit.so.4". (I already have a version of this file and I know that it works. It's about an official source I can post.)

 

Message 8 of 44 (27,588 Views)
rgo
Casual Adventurer

Final procedure for el6:

 

1) Start with the "dynamic" version, which for example goes to /usr/local/skype

 

2) Replace the skype binary in this folder with the one from the Ububtu 10 package.

 

3) Put a copy of Ubuntu's 'libQtWebKit.so.4" in this folder. You can get the package from here: http://packages.ubuntu.com/lucid-updates/i386/libqt4-webkit/download

 

4) move the skype binary to skype.bin and make an executable 'skype' script that contains:

 

#!/bin/sh
export LD_LIBRARY_PATH=/usr/local/skype
exec /usr/local/skype/skype.bin --resources=/usr/local/skype "$@"

 

Extracting files from a deb package goes like this:

 

$ ar x foo.deb

 

The files are then in either 'data.tar.gz' or 'data.tar.lzma'.

Message 9 of 44 (27,543 Views)
Novel Adventurer

Thanks! That worked great!

 

For those who aren't familiar with extracting tar.lzma archives, you can use

 

# tar --lzma -xvf data.tar.lzma

 

to extract them. Do the extraction in a temp directory so it's easy to clean up later.

 

The whle think could probably be scripted...

Message 10 of 44 (27,459 Views)
Discussion Stats