By using this site you agree to the use of cookies for analytics, personalised content and ads. Read more

Skype bug typing accents in chat windows?

This topic has been archived. To keep discussions in the Skype Community relevant we archive topics that haven't seen activity in the past 6 months. Read more about about archiving
Novel Tourist

Greetings,

 

Ever since i configured IBus in my Ubuntu 11.04 with both the Portuguese PT and the Japanese inputs, i lost the ability to correctly write in Portuguese, since the accents don't get typed properly. For example, if i try to write "á" it always types "´a". I tried with other programs, including various text editors, and i only have this problem with skype in the chat windows.

 

Does anyone have any idea how to solve this?

 

Apparently it's only a skype problem working with IBus since i haven't got this problem with any other program in Ubuntu so far, and it was working well before i set it to work with the Japanese input, that by the way, is working just fine.

Message 1 of 8 (2,331 Views)
7 Replies
Novel Adventurer

I am having the same problem. I running Arch Linux with skype 4.1.0.20-2. I keyboard switch between Greek and English and the problem only occurs in Skype.

 

Edit: It appears to be a bug within QT applications.

Message 2 of 8 (2,108 Views)
Novel Tourist
No solution yet? I have the same issue on Ubuntu 12.10 64bits. It appears once I configurated IBus.
Message 3 of 8 (2,053 Views)
Novel Adventurer

Hi,

 

I have the same problem with Fedora 18 64bits.

 

But in Fedora 17 64bits was working fine.

Message 4 of 8 (1,982 Views)
Novel Tourist

Not sure if it will work on Debian based distros, but this works fine in Fedora 18:

 

yum install ibus-qt.i686

 

Then, in a terminal:

export QT_IM_MODULE=ibus

 

You can make the change permanent by placing the line above in your .bashrc file.

 

 

Message 5 of 8 (1,837 Views)
Novel Adventurer
I tried this on Arch Linux with no success.
Message 6 of 8 (1,828 Views)
Novel Tourist

I'm having the same issue on manjaro 3.8.13-1-MANJARO skype 4.2.0.11 in latam spanish. When typing ´a I get ´a instead of the expected á

Message 7 of 8 (1,529 Views)
Casual Tourist

I'm actually suddenly having the same problem in Windows 7.  All of a sudden 'e is creating an accented "e"  rather than typing the actual strokes correctly.  Don't think this is limited to Linux.  Checked language settings and it's set for English.  It is also not windows keyboard settings I removed the international keyboard option and I am able to type normally in other applications.  Skype is the only one doing this.

Discussion Stats
  • 7 replies
  • 2332 views
  • 5 kudos
  • 7 in conversation