By using this site you agree to the use of cookies for analytics, personalised content and ads. Read more

Skype 4 drops calls when answering.

This topic has been archived. To keep discussions in the Skype Community relevant we archive topics that haven't seen activity in the past 6 months. Read more about about archiving
Casual Adventurer

Everytime someone calls me, I click to answer and skype drops the call. I don't get the call dropped message or anything, the call just dissapears. Skype worked great before I upgraded to version 4. Is anyone else having this issue?

See more topics labeled with:

Message 1 of 30 (8,734 Views)
29 Replies
Casual Adventurer

Just downgraded back to 2.2, couldn't figure this out an it's killing me!!!!

Really liked the interface updates in 4 though, thanks Skype team. Looking forward to the next version, perhaps my problem will be fixed.

 

Message 2 of 30 (8,700 Views)
Casual Adventurer

Where did you get the old 2.2 package from?

Message 3 of 30 (8,696 Views)
Casual Adventurer

luckily it was left in my downloads folder from long ago, I couldn't find it on the skype page anywhere

Message 4 of 30 (8,693 Views)
Casual Adventurer
Also seeing exactly this problem, running on Slackware 13.37 32bit. I'm able to call out but call drops immediately and call window never appears if I answer a call. I'd be interested in a solution apart from having to downgrade to old version.
Message 5 of 30 (8,684 Views)
Casual Adventurer

It would be great if a solution could be found. I don't see anything odd in my logs. I'm using debian squeeze 32 bit , 3.3 kernel, and KDE desktop. I also have another PC running xubuntu. Everything works fine there. Seems to be a rare issue, I don't have any idea what could cause it.

Message 6 of 30 (8,665 Views)
Novel Tourist

Am having the exact same problem. Can making outgoing calls just fine, incoming calls get dropped when I click to answer. Happens on Skype net calls and SkypeIn calls. I'm running Debian testing (wheezy) on amd64 with all packages updated.

Message 7 of 30 (8,627 Views)
Novel Adventurer

I was having this problem with Skype 4 and Arch (64 bit).  I deleted my ~/.Skype folder, which was the same one I originally had from Skype 2, and I have not had a problem answering calls since.

Message 8 of 30 (8,589 Views)
Casual Adventurer

This solution worked for me also.  Shut down skype.  Remove (or rename) .Skype directory.  Start up skype so new .Skype directory gets created.  Able to answer calls without call window vanishing.  Thanks!

 

Something in .Skype directory hung over from Skype 2.x causes problem for Skype 4.  The quick  skim of the diffs - too numerous to pinpoint anything in particular. 

Message 9 of 30 (8,564 Views)
Casual Adventurer

OK, I removed Skype 2.x via apt-get purge. Removed the .Skype directory by rm -Rvf .Skype. Re-installed skype 4.x had a few people try to call and I still can't answer PSTN calls get a busy signal, calls from a skype use go to voicemail.

Message 10 of 30 (8,550 Views)
Discussion Stats
  • 29 replies
  • 8735 views
  • 15 kudos
  • 9 in conversation