By using this site you agree to the use of cookies for analytics, personalised content and ads. Read more

Secondary account in Skype 4.0

SOLVED
Go to Solution
This topic has been archived. To keep discussions in the Skype Community relevant we archive topics that haven't seen activity in the past 6 months. Read more about about archiving
Novel Adventurer

How to open two Skype clients on Linux?

Message 1 of 18 (9,039 Views)
2 Accepted Solutions

Accepted Solutions
Novel Adventurer
Solution
Accepted as a solution by serres
‎28-08-2015 11:00

I have the same issue. Found this workaround:

 

1: Stop all running skype instances. 

2: Copy the directory where skype stores its options: [in home directory] cp -a .Skype .Skype2

3: Start one instance as usual

4: Start the second with skype --dbpath=~./.Skype2

 

Hope that helps...

View solution in original post

Message 3 of 18 (9,198 Views)
Novel Adventurer
Solution
Accepted as a solution by serres
‎28-08-2015 11:00
Message 4 of 18 (9,191 Views)
17 Replies
Novel Adventurer
Same issue
skype --secondary
got: skype: unrecognized option '--secondary'
skype /secondary
got: opened previously loaded skype.
Message 2 of 18 (9,024 Views)
Novel Adventurer
Solution
Accepted as a solution by serres
‎28-08-2015 11:00

I have the same issue. Found this workaround:

 

1: Stop all running skype instances. 

2: Copy the directory where skype stores its options: [in home directory] cp -a .Skype .Skype2

3: Start one instance as usual

4: Start the second with skype --dbpath=~./.Skype2

 

Hope that helps...

Message 3 of 18 (9,199 Views)
Novel Adventurer
Solution
Accepted as a solution by serres
‎28-08-2015 11:00
Thanks!
It works.
Message 4 of 18 (9,192 Views)
Novel Adventurer
Thanks
Message 5 of 18 (8,986 Views)
Novel Tourist
Hi spitfire2312,

Many thanks for figuring this out and posting it, I have been able to update my start up shell scripts. I now have my multiple accounts back up and running. Kudos much deserved.
Message 6 of 18 (8,936 Views)
Novel Adventurer
great! thanks! I have three accounts which I used to use simultaneously, I can start two using this method, but not the third... any ideas?
Message 7 of 18 (8,618 Views)
Novel Adventurer
Hey warfie3667 I don't see any reason why it should't work. Just create a third option directory by cp -a .Skype .Skype3 and start your third instance with skype --dbpath=~/.Skype3 I would be surprised if it doesn't work. Could you try and report your result?
Message 8 of 18 (8,613 Views)
Novel Adventurer

Hi spitfire2312,

I tried exactly as you suggested and that's what didn't work...

What *DID* work was when I started all three accounts in one command with & between each one.

 

eg: skype --dbpath=~/.Skype1 & skype --dbpath=~/.Skype2 & skype --dbpath=~/.Skype3

 

Hope this helps someone else.

Message 9 of 18 (8,609 Views)
Highlighted
Novel Tourist

You can use the same solution as for MacOS. For linux it will be:

 

sudo su -c "nohup skype && exit" (type this in terminal)

 

 

The advantage is that when you close terminal window the skype still working

Message 10 of 18 (8,606 Views)
Discussion Stats
  • 17 replies
  • 9040 views
  • 4 kudos
  • 9 in conversation