By using this site you agree to the use of cookies for analytics, personalised content and ads. Read more

[Package] Skype x86_64 RPM for Fedora

This topic has been archived. To keep discussions in the Skype Community relevant we archive topics that haven't seen activity in the past 6 months. Read more about about archiving
Novel Adventurer

Hi! 


Just wanted to comment that I've successfully made a 64 bit RPM Fedora package
for the last available version of Skype for Linux (2.2 BETA) and it works awesome! Just came to post it here in case the Skype developers see it and maybe get interested. I also want to mention that I did not make anthing illegal while making this package and also it's worth to mention that the package may
also work on OpenSUSE, Mandriva and other RPM Distros (But I'm not sure as I didn't test that); it would be great if you test the package and give me some feedback

If you're interested, you can download the package from:



And if you like it, I would like that someone makes it available from the official downloads page, so the users can choose it/get it officially if they're interested.

Thanks For Your Attention,

Have a Nice Day!!

-- 

Manuel Escudero
 
[edited for privacy]
Message 1 of 21 (43,928 Views)
20 Replies
Novel Tourist

Fails to install on a F16 based distribution with:

 

      libQtCore.so.4 is needed by skype-2.2.0.35-2.x86_64
        libQtDBus.so.4 is needed by skype-2.2.0.35-2.x86_64
        libQtGui.so.4 is needed by skype-2.2.0.35-2.x86_64
        libQtNetwork.so.4 is needed by skype-2.2.0.35-2.x86_64
        libX11.so.6 is needed by skype-2.2.0.35-2.x86_64
        libXext.so.6 is needed by skype-2.2.0.35-2.x86_64
        libXss.so.1 is needed by skype-2.2.0.35-2.x86_64
        libXv.so.1 is needed by skype-2.2.0.35-2.x86_64
        libasound.so.2 is needed by skype-2.2.0.35-2.x86_64
        libasound.so.2(ALSA_0.9) is needed by skype-2.2.0.35-2.x86_64
        libasound.so.2(ALSA_0.9.0rc4) is needed by skype-2.2.0.35-2.x86_64
        libc.so.6 is needed by skype-2.2.0.35-2.x86_64
        libc.so.6(GLIBC_2.0) is needed by skype-2.2.0.35-2.x86_64
        libc.so.6(GLIBC_2.1) is needed by skype-2.2.0.35-2.x86_64
        libc.so.6(GLIBC_2.1.3) is needed by skype-2.2.0.35-2.x86_64
        libc.so.6(GLIBC_2.2) is needed by skype-2.2.0.35-2.x86_64
        libc.so.6(GLIBC_2.3) is needed by skype-2.2.0.35-2.x86_64
        libc.so.6(GLIBC_2.3.4) is needed by skype-2.2.0.35-2.x86_64
        libc.so.6(GLIBC_2.4) is needed by skype-2.2.0.35-2.x86_64
        libdl.so.2 is needed by skype-2.2.0.35-2.x86_64
        libdl.so.2(GLIBC_2.0) is needed by skype-2.2.0.35-2.x86_64
        libdl.so.2(GLIBC_2.1) is needed by skype-2.2.0.35-2.x86_64
        libgcc_s.so.1 is needed by skype-2.2.0.35-2.x86_64
        libgcc_s.so.1(GCC_3.0) is needed by skype-2.2.0.35-2.x86_64
        libgcc_s.so.1(GLIBC_2.0) is needed by skype-2.2.0.35-2.x86_64
        libm.so.6 is needed by skype-2.2.0.35-2.x86_64
        libm.so.6(GLIBC_2.0) is needed by skype-2.2.0.35-2.x86_64
        libm.so.6(GLIBC_2.1) is needed by skype-2.2.0.35-2.x86_64
        libpthread.so.0 is needed by skype-2.2.0.35-2.x86_64
        libpthread.so.0(GLIBC_2.0) is needed by skype-2.2.0.35-2.x86_64
        libpthread.so.0(GLIBC_2.1) is needed by skype-2.2.0.35-2.x86_64
        libpthread.so.0(GLIBC_2.2) is needed by skype-2.2.0.35-2.x86_64
        libpthread.so.0(GLIBC_2.3.2) is needed by skype-2.2.0.35-2.x86_64
        librt.so.1 is needed by skype-2.2.0.35-2.x86_64
        librt.so.1(GLIBC_2.2) is needed by skype-2.2.0.35-2.x86_64
        libstdc++.so.6 is needed by skype-2.2.0.35-2.x86_64
        libstdc++.so.6(CXXABI_1.3) is needed by skype-2.2.0.35-2.x86_64
        libstdc++.so.6(GLIBCXX_3.4) is needed by skype-2.2.0.35-2.x86_64
        libstdc++.so.6(GLIBCXX_3.4.9) is needed by skype-2.2.0.35-2.x86_64

Message 2 of 21 (43,370 Views)
Novel Tourist

It still wants to install the following i686 dependencies... (Fedora-16)

alsa-lib, dbus-libs, gamin, glib2, keyutils-libs, krb5-libs, libXScrnSaver, libXdamage,

libXv, libXxf86vm, libcom_err, libdrm, libffi, libpciaccess, libselinux, libtiff i686, llvm-libs,

mesa-dri-drivers, mesa-dri-filesystem, mesa-libGL, ncurses-libs, openssl, qt, qt-x11, readline, sqlite

Message 3 of 21 (43,275 Views)
Novel Tourist
What is the solution for the upside down camera. I could fix that in 32 bit version on 64 bit Fedora 16.

The 32 bit skype can be installed on 64 bit fedora by downloading the 32 bit rpm of skype and installing following dependencies,

# yum -y install libXv.i686 libXScrnSaver.i686 qt.i686 qt-x11.i686 pulseaudio-libs.i686 pulseaudio-libs-glib2.i686 alsa-plugins-pulseaudio.i686 libv4l.i686
# yum -y install skype-2.2.0.35-fedora.i586.rpm (after downloading from skype.com)
# mv /usr/bin/skype /usr/bin/skype.main

and place the following content in "/usr/bin/skype"
-----------------------------------------------------------------------------------------------------
#!/bin/bash
export LIBV4LCONTROL_FLAGS=3
LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so /usr/bin/skype.main
-------------------------------------------------------------------------------------------------------
Make it executable
# chmod 755 /usr/bin/skype
Message 4 of 21 (43,259 Views)
Novel Adventurer

works for me!

Message 5 of 21 (42,786 Views)
Novel Adventurer

The regular fedora package installed fine. Im on a 64bit box.

Message 6 of 21 (42,589 Views)
Novel Adventurer

Hi,

 

I've just installed your package by

yum install skype-2.2.0.35-2.x86_64.rpm
but it again installs the whole bunch of 32-bit libraries... as the "official" 32-bit one does.

 

What am I missing?

 

Many thanks for your kind effort !!

 

Cheers,

- Anatoly

Message 7 of 21 (42,508 Views)
Novel Adventurer

Thanks, it works!
The skype-2.2.0.35-2.x86_64.rpm package works fine on a Fedora Core 16 64b. Previously, I had to uninstall the previous version (skype-2.2.0.35-fedora.i586.rpm) in order to avoid conflicts.

Message 8 of 21 (42,467 Views)
Casual Adventurer
Installs/works for me! f16. Do you know if there will be any new future releases?
Message 9 of 21 (42,306 Views)
Casual Adventurer

Ok, today skype 64bit started segfaulting on f16 for me.  I guess I have to go back to 32bit version, unless you have any ideas?  I even tried rebooting and moving .Skype dir.  no go.

Message 10 of 21 (42,279 Views)
Discussion Stats